Bug #52667 [Fbk->Wfx]: memory_limit ignored
| From: | kalle@php.net | Date: | Sun, 22 Aug 2010 15:15:25 +0000 |
| Subject: | Bug #52667 [Fbk->Wfx]: memory_limit ignored | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-153700@lists.php.net to get a copy of this message | ||
Edit report at http://bugs.php.net/bug.php?id=52667&edit=1
ID: 52667
Updated by: kalle@php.net
Reported by: j dot chetwynd at btinternet dot com
Summary: memory_limit ignored
-Status: Feedback
+Status: Wont fix
Type: Bug
Package: PHP options/info functions
Operating System: os x leopard
PHP Version: 5.2.14
Block user comment: N
New Comment:
Thanks, 5.2 only gets security updates so this is a Wont fix :)
Previous Comments:
------------------------------------------------------------------------
[2010-08-22 16:53:18] j dot chetwynd at btinternet dot com
sorry, I could not find a way to login, comment or close this bug.
has been resolved since updating to 5.3
------------------------------------------------------------------------
[2010-08-22 16:23:12] kalle@php.net
Im not sure I totally understand your issue. So you are saying, that if
you set memory_limit to 20 (20 bytes) then you do not get any startup
error?
------------------------------------------------------------------------
[2010-08-22 15:41:03] j dot chetwynd at btinternet dot com
Description:
------------
php.ini:
memory_limit = 20 ; 20 Bytes not: Maximum amount of memory a script
may consume (128MB)
phpinfo:
memory_limit 20 20
seems clear to me at least that any web app on this server should crash,
or send error, but it does not:
ie like: Bug #52549: No 'M' in memory_limit variable returns 'Could not
startup.'
but app runs fine!
> memory-limit is always enabled (--enable-memory-limit removed)
> default value if memory-limit is set to 128M
http://bugs.php.net/42525
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/bug.php?id=52667&edit=1