Bug #52704 [Opn->Fbk]: php.ini error for error_log parameter

From: Date: Thu, 26 Aug 2010 17:29:08 +0000
Subject: Bug #52704 [Opn->Fbk]: php.ini error for error_log parameter
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-153821@lists.php.net to get a copy of this message
Edit report at http://bugs.php.net/bug.php?id=52704&edit=1 ID: 52704 Updated by: pajoye@php.net Reported by: pfenderd at bellsouth dot net Summary: php.ini error for error_log parameter -Status: Open +Status: Feedback Type: Bug Package: PHP options/info functions Operating System: Windows Vista Ultimate - 32bit PHP Version: 5.2.14 Block user comment: N Previous Comments: ------------------------------------------------------------------------ [2010-08-26 19:28:57] pajoye@php.net How do you change it? In the same php.ini? However, the ISAPI is not supported anymore. The FastCGI is the interface being recommended to be used with IIS (all versions). ------------------------------------------------------------------------ [2010-08-26 05:27:37] pfenderd at bellsouth dot net Description: ------------ Using IIS7 in ISAPI mode, the php.ini file is not allowed to change the value of error_log. When installed, error_log="C:\Windows\temp\php-errors.log" Attempted to change to a new folder path error_log="C:\PHP\logs\php-errors.log" It worked properly with the windows temp folder, but not the next location. The "C:\PHP\logs" folder has full permissions for anyone. The file "php-errors.log" is created by PHP in the new folder when it starts processing a web page, but then generates error 500. There are 31 websites running on this server. They all ran properly with PHP version 5.2.6, but all fail with 5.2.14. Changing back to the windows temp folder always makes PHP work properly. This is a repeatable problem. It is not related to the content of the PHP file being parsed. There is no problem with the parameters for "upload_tmp_dir=" and "session.save_path=" using the new folder: upload_tmp_dir="C:\PHP\tmp" session.save_path="C:\PHP\tmp" ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/bug.php?id=52704&edit=1

« previous php.bugs (#153821) next »