Bug #52710 [NEW]: Session Disappears
| From: | diemuzi at gmail dot com | Date: | Thu, 26 Aug 2010 20:11:53 +0000 |
| Subject: | Bug #52710 [NEW]: Session Disappears | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-153829@lists.php.net to get a copy of this message | ||
From:
Operating system: Archlinux
PHP version: 5.3.3
Package: FPM related
Bug Type: Bug
Bug description:Session Disappears
Description:
------------
It appears when running PHP 5.3.3 with FPM support sessions disappear on
almost every-other request. The session name stays the same, but any
application using a session returns a blank page until the page has been
refreshed again.
Currently I have the session.save_path to /tmp, I tested other locations
but the same issue. (This did not occur with FastCGI/CGI). As another test
I changed the location of the save_path and loaded a phpinfo() script. It
showed the corrected changed location, however upon refresh it was changed
back to /tmp. Another refresh and the location was again changed to the
path I specified. When the path changes, it does not write a new session
file in either location.
The error in the error log is always:
FastCGI: server stdeer: PHP Fatal error
session_start(); open(/tmp/session_name_here, O_RDWR) failed: Permission
denied(13) Array
Testing with random permissions ranging from 0644, 0666, 0755, 0777 return
the same results. I also attempted to change the permissions to the actual
session file and the same results.
--
Edit bug report at http://bugs.php.net/bug.php?id=52710&edit=1
--
Try a snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=52710&r=trysnapshot52
Try a snapshot (PHP 5.3): http://bugs.php.net/fix.php?id=52710&r=trysnapshot53
Try a snapshot (trunk): http://bugs.php.net/fix.php?id=52710&r=trysnapshottrunk
Fixed in SVN: http://bugs.php.net/fix.php?id=52710&r=fixed
Fixed in SVN and need be documented: http://bugs.php.net/fix.php?id=52710&r=needdocs
Fixed in release: http://bugs.php.net/fix.php?id=52710&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=52710&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=52710&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=52710&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=52710&r=support
Expected behavior: http://bugs.php.net/fix.php?id=52710&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=52710&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=52710&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=52710&r=globals
PHP 4 support discontinued: http://bugs.php.net/fix.php?id=52710&r=php4
Daylight Savings: http://bugs.php.net/fix.php?id=52710&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=52710&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=52710&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=52710&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=52710&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=52710&r=mysqlcfg