Bug #52993 [Opn->Csd]: error while loading configured libphp5.so
| From: | klus dot vit at gmail dot com | Date: | Wed, 13 Oct 2010 08:42:50 +0000 |
| Subject: | Bug #52993 [Opn->Csd]: error while loading configured libphp5.so | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-155139@lists.php.net to get a copy of this message | ||
Edit report at http://bugs.php.net/bug.php?id=52993&edit=1
ID: 52993
User updated by: klus dot vit at gmail dot com
Reported by: klus dot vit at gmail dot com
Summary: error while loading configured libphp5.so
-Status: Open
+Status: Closed
Type: Bug
Package: Other web server
Operating System: openSUSE 11.3 (x86_64)
PHP Version: 5.3.3
Block user comment: N
New Comment:
Thanks for the answer, uramihsayibok.
I have 32 bit IBM HTTP Server.
But I've solved the problem.
First of all I set flag: export CFLAGS="-m32"
Then I installed the glibc-devel library for i386. Without that the
./configure
doesn't want to start with the error "C compiler cannot create
executables"
Then I installed i386 libraries that are using in ./configure and
created
symbolic link ln -s /home/db2inst1/sqllib/lib32
/home/db2inst1/sqllib/lib for
using 32-bit DB2 libraries for compilation(DB2 was 64-bit ESE).
After that the ./configure, make and make install passed with success
and the
server started.
Previous Comments:
------------------------------------------------------------------------
[2010-10-13 03:32:01] uramihsayibok at gmail dot com
You sure you have a 64-bit Apache? Compare the output of
$ file /opt/IBM/HTTPServer/modules/libphp5.so
with what
file -L says on your Apache binary (check /usr/sbin/apache
or apache2 or httpd)
------------------------------------------------------------------------
[2010-10-05 16:00:38] klus dot vit at gmail dot com
Description:
------------
I've configured php for the IBM HTTP Server v7.0.0 on a 64bit openSUSE
11.3
(x86_64) by the configure string:
./configure --with-ibm-db2=/opt/ibm/db2/V9.7 --with-
apxs2=/opt/IBM/HTTPServer/bin/apxs --with-freetype-
dir=/usr/include/freetype2/freetype --without-mysql --with-gd=/usr/
--with-png-
dir=/usr/lib --with-zlib-dir=/usr/lib --disable-cli --with-config-file-
path=/usr/local/lib --with-ldap --with-pear --with-openssl
After executing "apacheclt start" I got the message:
httpd: Syntax error on line 163 of /opt/IBM/HTTPServer/conf/httpd.conf:
Cannot
load /opt/IBM/HTTPServer/modules/libphp5.so into server:
/opt/IBM/HTTPServer/modules/libphp5.so: wrong ELF class: ELFCLASS64
I can't change the gcc on this server.
What is needed to compile libphp5.so properly for this system?
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/bug.php?id=52993&edit=1