Bug #1164 [Com]: Unable to connect to PostgreSQL, unsupported protocol

From: Date: Mon, 01 Nov 2010 11:07:55 +0000
Subject: Bug #1164 [Com]: Unable to connect to PostgreSQL, unsupported protocol
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-155675@lists.php.net to get a copy of this message
Edit report at http://bugs.php.net/bug.php?id=1164&edit=1

 ID:                 1164
 Comment by:         lakshmi at nace dot co dot in
 Reported by:        B dot Ogryczak at students dot mimuw dot edu dot pl
 Summary:            Unable to connect to PostgreSQL, unsupported
                     protocol
 Status:             Closed
 Type:               Bug
 Package:            PostgreSQL related
 Operating System:   Linux (RH 5.2)
 PHP Version:        3.0.5
 Block user comment: N

 New Comment:

i couldnt able to connect to postgresql database, when i am using
pg_connect it is simply throwing an error as undefined function
pg_connect()


Previous Comments:
------------------------------------------------------------------------
[1999-02-20 12:49:15] eschmid

It's not a PHP problem. Can you connect throu the psql-monitor? If you
can, 
you should be able to connect from PHP as well.

------------------------------------------------------------------------
[1999-02-19 12:07:47] B dot Ogryczak at students dot mimuw dot edu dot
pl

Since version 6.4.x PostgreSQL introduced new 
frontend/backend protocol (v 2.0), even tho I
recompiled PHP3 with the new libpg it doesn't
support this protocol. I get error:

Unable to connect to PostgreSQL server,
Unsupported frontend protocol in ...

I'm running Linux, RH 5.2 with PostgreSQL 6.4.2
PHP 3.0.5.




------------------------------------------------------------------------



-- 
Edit this bug report at http://bugs.php.net/bug.php?id=1164&edit=1


Thread (1 message)

  • lakshmi at nace dot co dot in
  • Unknown Message
    • lakshmi at nace dot co dot in
« previous php.bugs (#155675) next »