#14076 [Com]: fopen() and touch() fail to create file under safe mode

From: Date: Tue, 30 Jul 2002 16:40:03 +0000
Subject: #14076 [Com]: fopen() and touch() fail to create file under safe mode
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-15607@lists.php.net to get a copy of this message
ID: 14076 Comment by: phpbugs@noerenberg.de Reported By: a.genkin@utoronto.ca Status: Feedback Bug Type: *Directory/Filesystem functions Operating System: Linux PHP Version: 4.0.6 New Comment: I can not check if this bug has been solved (php4-200207300900 does not install correctly and produces segfaulting apache childs). I'll check back next week and provide feedback asap. Maybe someone can give me a hint where (CVS) to find the necessary code-changes and whether it is possible to back-port some to the current php-stable. Hajo Previous Comments: ------------------------------------------------------------------------ [2002-07-10 23:49:48] sniper@php.net Please try this snapshot: http://snaps.php.net/php4-latest.tar.gz ------------------------------------------------------------------------ [2002-05-04 03:55:59] a.genkin@utoronto.ca I don't seem to be able to change the status to Open... How do I do it?! ------------------------------------------------------------------------ [2002-05-04 03:53:18] a.genkin@utoronto.ca Erm... Hajo provided feedback. ------------------------------------------------------------------------ [2002-05-04 00:00:04] php-bugs@lists.php.net No feedback was provided for this bug for over a month, so it is being suspended automatically. If you are able to provide the information that was originally requested, please do so and change the status of the bug back to "Open". ------------------------------------------------------------------------ [2002-04-17 03:35:34] phpbugs@noerenberg.de byg@cf1.ru wrote: >I could not reproduce this issue. >Here's my layout for the virtual server (from httpd.conf) The symlink has to be *within* path_to_site, e.g.: /var/www/ = symlink to /mnt/sda1/www /var/www/domain.com = apache document_root = php open_basedir Please see my posting from 16 Jan 1:21pm for details ( http://bugs.php.net/bug.php?id=14076 ). Hajo ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/14076 -- Edit this bug report at http://bugs.php.net/?id=14076&edit=1

« previous php.bugs (#15607) next »