Bug #53506 [Opn->Csd]: Error in fpm_conf_set_integer
| From: | fat@php.net | Date: | Thu, 09 Dec 2010 17:41:18 +0000 |
| Subject: | Bug #53506 [Opn->Csd]: Error in fpm_conf_set_integer | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-156842@lists.php.net to get a copy of this message | ||
Edit report at http://bugs.php.net/bug.php?id=53506&edit=1
ID: 53506
Updated by: fat@php.net
Reported by: d dot hagen at mittwald dot de
Summary: Error in fpm_conf_set_integer
-Status: Open
+Status: Closed
Type: Bug
Package: FPM related
Operating System: Linux
PHP Version: 5.3.3
-Assigned To:
+Assigned To: fat
Block user comment: N
Private report: N
New Comment:
This bug has been fixed in SVN.
Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
Thank you for the report, and for helping us make PHP better.
This has been corrected and will be available in the next release of PHP
(5.3.4
coming soon)
Previous Comments:
------------------------------------------------------------------------
[2010-12-09 13:40:36] d dot hagen at mittwald dot de
Description:
------------
The following configuration directive
>>
pm.max_children = 15[:space:]
<<
fails with "unable to parse value for entry 'pm.max_children': is not
a valid number (greater or equal than zero)". The [:space:] causes the
error.
fpm_conf.c -> fpm_conf_set_integer -> val[0] = '1' ,val[1]='5'
,val[2]='
'
generally the parser should ignore whitespace and tab values (hm..bug or
feature?)
Test script:
---------------
insert the following in the fpm.conf
>>
pm = dynamic
pm.max_children = 150
pm.start_servers = 10
pm.min_spare_servers = 10
pm.max_spare_servers = 20
<<
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/bug.php?id=53506&edit=1