Bug #53771 [Fbk->Bgs]: Apache 2.2 will not start with Interbase enabled
| From: | pajoye@php.net | Date: | Tue, 18 Jan 2011 07:55:34 +0000 |
| Subject: | Bug #53771 [Fbk->Bgs]: Apache 2.2 will not start with Interbase enabled | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-157970@lists.php.net to get a copy of this message | ||
Edit report at http://bugs.php.net/bug.php?id=53771&edit=1
ID: 53771
Updated by: pajoye@php.net
Reported by: jackmason at mindspring dot com
Summary: Apache 2.2 will not start with Interbase enabled
-Status: Feedback
+Status: Bogus
Type: Bug
Package: InterBase related
Operating System: Windows 7
PHP Version: 5.3.5
Block user comment: N
Private report: N
New Comment:
Sorry, but your problem does not imply a bug in PHP itself. For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system
is not the
appropriate forum for asking support questions. Due to the volume
of reports we can not explain in detail here why your report is not
a bug. The support channels will be able to provide an explanation
for you.
Thank you for your interest in PHP.
The Firebird libraries are required to use interbase extensions. They
have to be
in your PATH. Test it under CLI to see the error (DLLs not found) or
enable/read
apache's error log.
Previous Comments:
------------------------------------------------------------------------
[2011-01-18 04:50:50] aharvey@php.net
Have you followed the instructions at
http://php.net/manual/en/ibase.installation.php
-- in particular,
ensuring that gds32.dll is in the PATH?
------------------------------------------------------------------------
[2011-01-17 23:49:58] jackmason at mindspring dot com
Description:
------------
Adding "extension=php_interbase.dll" to the end of php.ini causes Apache
2.2 to fail to start ANY services. Without
"extension=php_interbase.dll", ibase_connect fails as an undefined
function, so Interbase is not enabled as a service by default even
though php.ini contains the basic defaults such as
"ibase.allow_persistent = 1".
This system is also running PHPEd, with its associated PHP which works
fine. When bypassing Apache and confining the pages to PHPEd, everything
works. The "extension=php_interbase.dll" is in the PHPEd php.ini. The
InterBase server is running on this system, and PHPEd has no trouble
finding it without any explicit directions.
Either there is another way to enable InterBase on 5.35, or something is
wrong.
Test script:
---------------
$DBUser='MAINUSER';
$DBPass='MAINPASS';
$DB=ibase_connect('127.0.0.1:C:/SDB/George.gdb', $DBUser, $DBPass);
Expected result:
----------------
ibase_connect should be recognized as a valid function.
Actual result:
--------------
ibase_connect is declared an undefined function.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/bug.php?id=53771&edit=1