Edit report at http://bugs.php.net/bug.php?id=53572&edit=1
ID: 53572
Comment by: anthon dot pang at gmail dot com
Reported by: admin at xaker1 dot ru
Summary: Bug appeared in php 5.2.15, FastCGI
Status: Open
Type: Bug
Package: Unknown/Other Function
Operating System: FreeBSD 8.1
PHP Version: 5.2.16
Block user comment: N
Private report: N
New Comment:
Just an observation, but ini the php.ini for the affected account, the
open_basedir setting has spaces in the paths.
Previous Comments:
------------------------------------------------------------------------
[2011-01-14 17:42:37] admin at xaker1 dot ru
Error disappears if you disable open_basedir
------------------------------------------------------------------------
[2010-12-20 19:36:53] markusb at gmx dot at
Same probleme
We use php (cgi) and open_basedir > all php scrips > No input file
specified.
------------------------------------------------------------------------
[2010-12-19 09:05:26] admin at xaker1 dot ru
The problem exists on php 5.2.15 and php 5.2.16.
I'm using php 5.2.14, as work is needed for all sites.
php.ini on the affected account:
register_globals = Off
display_errors = Off
log_errors = On
max_execution_time = 30
memory_limit = 128M
upload_max_filesize = 16M
post_max_size = 16M
session.save_path = "/ home/saki2/data/tmp"
upload_tmp_dir = "/ home/saki2/data/tmp"
open_basedir = "/ home/saki2: / tmp: / var / tmp"
; [suhosin]
; suhosin.log.syslog = E_ALL & ~ S_SQL
; suhosin.log.sapi = E_ALL & ~ S_SQL
; suhosin.executor.include.max_traversal = 4
; suhosin.executor.func.blacklist = popen, dl, passthru, system, exec,
proc_open, shell_exec, proc_close, symlink
; WARNING!!!!
; Or eAccelerator or Zend!!!
; Not twice!!!
; [eAccelerator]
; zend_extension = "/ usr/local/lib/php/20060613/eaccelerator.so"
; eaccelerator.cache_dir = "/ home/saki2/data/tmp"
; eaccelerator.debug = "0"
; eaccelerator.shm_size = "16"
; [Zend]
; zend_optimizer.optimization_level = 15
; zend_extension_manager.optimizer = "/
usr/local/lib/php/20060613/Optimizer"
; zend_extension_manager.optimizer_ts = "/
usr/local/lib/php/20060613/Optimizer_TS"
; zend_extension = "/
usr/local/lib/php/20060613/ZendExtensionManager.so"
; zend_extension_ts = "/
usr/local/lib/php/20060613/ZendExtensionManager_TS.so"
php.ini in the working account:
register_globals= Off
display_errors= On
log_errors= On
max_execution_time= 900
memory_limit= 512M
upload_max_filesize= 16M
post_max_size = 16M
session.save_path = "/home/bravohost/data/tmp"
upload_tmp_dir="/home/bravohost/data/tmp"
open_basedir = "/home/bravohost:/tmp:/var/tmp"
;[suhosin]
;suhosin.log.syslog = E_ALL & ~S_SQL
;suhosin.log.sapi = E_ALL & ~S_SQL
;suhosin.executor.include.max_traversal = 4
;suhosin.executor.func.blacklist =
popen,dl,passthru,system,exec,proc_open,shell_exec,proc_close,symlink
; WARNING!!!!
; or eAccelerator or Zend!!!
; not twice!!!
[eAccelerator]
zend_extension="/usr/local/lib/php/20060613/eaccelerator.so"
eaccelerator.cache_dir="/home/bravohost/data/tmp"
eaccelerator.debug="0"
eaccelerator.shm_size="16"
;[Zend]
;zend_optimizer.optimization_level=15
;zend_extension_manager.optimizer="/usr/local/lib/php/20060613/Optimizer"
;zend_extension_manager.optimizer_ts="/usr/local/lib/php/20060613/Optimizer_TS"
;zend_extension="/usr/local/lib/php/20060613/ZendExtensionManager.so"
;zend_extension_ts="/usr/local/lib/php/20060613/ZendExtensionManager_TS.so
;extension = filter.so
php modules are used:
[PHP Modules]
bcmath
bz2
calendar
ctype
curl
date
dom
filter
gd
gettext
hash
iconv
imap
ionCube Loader
json
libxml
mbstring
mcrypt
mhash
mysql
mysqli
openssl
pcre
PDO
pdo_mysql
pdo_sqlite
posix
Reflection
session
SimpleXML
sockets
SPL
SQLite
standard
suhosin
tokenizer
xml
xmlreader
xmlwriter
Zend Optimizer
zip
zlib
[Zend Modules]
Zend Extension Manager
Zend Optimizer
the ionCube PHP Loader
------------------------------------------------------------------------
[2010-12-18 22:14:48] cataphract@php.net
We'd need more information than what you gave. First, are you using
5.2.15 or 5.2.16. If you're using 5.2.15, upgrade.
Then, what exactly is causing this (not a vague it may be root folder or
name/group or open_basedir) and, preferably, steps to reproduce, would
go a long way.
Thanks.
------------------------------------------------------------------------
[2010-12-18 18:03:27] admin at xaker1 dot ru
If you downgrade to 5.2.14, the error disappears.
At the moment the causes of errors are found, ask for help.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/bug.php?id=53572
--
Edit this bug report at http://bugs.php.net/bug.php?id=53572&edit=1