Req #53857 [Opn->Bgs]: Pool definition errors
| From: | fat@php.net | Date: | Sat, 29 Jan 2011 10:22:51 +0000 |
| Subject: | Req #53857 [Opn->Bgs]: Pool definition errors | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-158307@lists.php.net to get a copy of this message | ||
Edit report at http://bugs.php.net/bug.php?id=53857&edit=1
ID: 53857
Updated by: fat@php.net
Reported by: samfiragabriel at gmail dot com
Summary: Pool definition errors
-Status: Open
+Status: Bogus
Type: Feature/Change Request
Package: FPM related
Operating System: GNU/Linux
PHP Version: 5.3.5
Block user comment: N
Private report: N
New Comment:
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to
report
a bug at http://bugs.php.net/how-to-report.php
If one of your configuration line is wrong, it's detected and FPM won't
start.
Here is the example you mentioned (non existant chroot dir) (in this
example
/nowhere does not exist)
# grep ^chroot /path/to/php-fpm.conf
chroot = /nowhere
# ./sapi/fpm/php-fpm
[29-Jan-2011 11:16:34] ERROR: [pool www_chroot] the chroot path
'/nowhere' does
not exist or is not a directory
[29-Jan-2011 11:16:34] ERROR: failed to post process the configuration
If you run php-fpm with --test, you can anticipate an configuration
error and
you won't restart FPM.
If you have a practical case which is not detected by the --test, please
open a
bug report and it'll be corrected.
thx
Previous Comments:
------------------------------------------------------------------------
[2011-01-27 17:08:30] samfiragabriel at gmail dot com
Description:
------------
It seams that if there is an error in the php-fpm config file, lets say
in one of the pools, then fpm just dies with an error.
For example, if you define a chroot value in one of the pools, and the
directory does not exist, the master process and all the other pools
just die upon SIGUSR2.
In a shared hosting environment much of the configuring is done via
scripts, and rarely by hand. If one value is erroneous, it would be
better if that particular pool is skipped instead of just dying all
together.
That way at least only one site will go down instead of all of them.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/bug.php?id=53857&edit=1