#18715 [NEW]: ldap_connect() generates 'Unresolved symbol:sasl_set_alloc' in apache error log

From: Date: Fri, 02 Aug 2002 21:23:27 +0000
Subject: #18715 [NEW]: ldap_connect() generates 'Unresolved symbol:sasl_set_alloc' in apache error log
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-15867@lists.php.net to get a copy of this message
From: patrick.thurier@renault.com Operating system: HP UX 11 PHP version: 4.2.2 PHP Bug Type: LDAP related Bug description: ldap_connect() generates 'Unresolved symbol:sasl_set_alloc' in apache error log Hello, When I run the following script : <? echo "<h3>LDAP query test</h3>"; echo "Connecting ..."; $ds=ldap_connect("server IP@"); echo "connect result is ".$ds."<p>"; ?> The browser tells me I've got a document with no data. Here's what I find in /usr/local/apache/logs/error_log : /usr/lib/dld.sl: Unresolved symbol: sasl_set_alloc (code) from /usr/local/lib/libldap.sl.2 [..snip..] /usr/lib/dld.sl: Unresolved symbol: sasl_set_alloc (code) from /usr/local/lib/libldap.sl.2 [Fri Aug 2 23:01:34 2002] [notice] child pid 16402 exit signal Abort (6) [Fri Aug 2 23:01:34 2002] [notice] child pid 16401 exit signal Abort (6) [Fri Aug 2 23:01:34 2002] [notice] child pid 16400 exit signal Abort (6) [Fri Aug 2 23:01:34 2002] [notice] child pid 16399 exit signal Abort (6) [Fri Aug 2 23:01:34 2002] [notice] child pid 16398 exit signal Abort (6) [Fri Aug 2 23:01:34 2002] [notice] child pid 16397 exit signal Abort (6) [Fri Aug 2 23:01:34 2002] [notice] child pid 16396 exit signal Abort (6) [Fri Aug 2 23:01:34 2002] [notice] child pid 16395 exit signal Abort (6) [Fri Aug 2 23:01:34 2002] [notice] child pid 16394 exit signal Abort (6) /usr/lib/dld.sl: Unresolved symbol: sasl_set_alloc (code) from /usr/local/lib/libldap.sl.2 /usr/lib/dld.sl: Unresolved symbol: sasl_set_alloc (code) from /usr/local/lib/libldap.sl.2 [Fri Aug 2 23:01:35 2002] [notice] child pid 16424 exit signal Abort (6) [Fri Aug 2 23:01:35 2002] [notice] child pid 16426 exit signal Abort (6) All the httpds are restarted. Everything went OK during the build of all packages. I'am running : HP-UX 11 apache 1.3.26 php 4.2.2 openldap 2.0.25 openssl 0.9.6d I built all with gcc 3.1 PHP configure : ./configure --with-mysql --with-gd --with-png --with-jpeg --with-pdflib=/usr/local --enable-ftp --with-apache=/logiciel/sources/apache_1.3.26 --with-tiff-dir=/usr/local --with-jpeg-dir=/usr/local --with-png-dir=/usr/local --with-zlib-dir=/usr/local --with-tiff-dir=/usr/local --with-snmp=/usr/local --enable-ucd-snmp-hack --with-ldap=/usr/local --with-mhash --with-mcrypt --with-openssl=/usr/local APACHE configure : /configure --prefix=/usr/local/apache --manualdir=/data_web/docweb/apache --with-port=8056 --activate-module=src/modules/php4/libphp4.a OPENLDAP configures ( I tried many ) : ./configure --disable-slapd --disable-slurpd --with-tls --with--cyrus-sasl ./configure --disable-slapd --disable-slurpd --with-tls --without--cyrus-sasl ./configure --disable-slapd --disable-slurpd --with-tls --without--cyrus-sasl --disable-shared I checked bug database and found something similar with linux (bug # 12830) Thank's for help. -- Edit bug report at http://bugs.php.net/?id=18715&edit=1 -- Fixed in CVS: http://bugs.php.net/fix.php?id=18715&r=fixedcvs Fixed in release: http://bugs.php.net/fix.php?id=18715&r=alreadyfixed Need backtrace: http://bugs.php.net/fix.php?id=18715&r=needtrace Try newer version: http://bugs.php.net/fix.php?id=18715&r=oldversion Not developer issue: http://bugs.php.net/fix.php?id=18715&r=support Expected behavior: http://bugs.php.net/fix.php?id=18715&r=notwrong Not enough info: http://bugs.php.net/fix.php?id=18715&r=notenoughinfo Submitted twice: http://bugs.php.net/fix.php?id=18715&r=submittedtwice register_globals: http://bugs.php.net/fix.php?id=18715&r=globals

« previous php.bugs (#15867) next »