#18725 [Opn]: multiple definitions of symbol __dig_vec
| From: | m31 at 128kb dot com | Date: | Sat, 03 Aug 2002 19:04:41 +0000 |
| Subject: | #18725 [Opn]: multiple definitions of symbol __dig_vec | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-15926@lists.php.net to get a copy of this message | ||
ID: 18725
User updated by: m31@128kb.com
Reported By: m31@128kb.com
Status: Open
Bug Type: Apache related
Operating System: Darwin OSX 10.1.5
PHP Version: 4.2.2
New Comment:
I installed DBD::Mysql via CPAN shell so I'm not sure about
that but the php build I'm using is, I installed the binary
from the suggested link on http://www.php.net/downloads.php
for the OSX binary.
I've been trying to build php with mysql's mysqlclient
libraries to avoid this but am having difficulties. I
wasn't aware that I could just try to rebuild DBD, maybe I
sould just try that route.... but how would I go about
doing that?? link DBD to mysqlclient libraries??
Previous Comments:
------------------------------------------------------------------------
[2002-08-03 14:49:21] msopacua@idg.nl
Hi,
this is a symbol in the mysql client library.
Did you compile the DBD::mysql module with the same library as the one
with PHP?
------------------------------------------------------------------------
[2002-08-03 13:26:53] m31@128kb.com
While using mod_php as a shared object and mod_perl as a
shared object I get dyld errors complaining about multiple
definitions of symbol __dig_vec. This error occurs when
perls DBI module is loaded into mod_perl and when a call to
Apache::DBI->connect() is made. The script fails with this
error:
dyld: /usr/sbin/httpd multiple definitions of symbol
__dig_vec
/usr/libexec/httpd/libphp4-4.1.2.so definition of __dig_vec
/Library/Perl/darwin/auto/DBD/mysql/mysql.bundle definition
of __dig_vec
This may not be exactly php specific but mod_php and
mod_perl have an obvious conflict and I'm not sure if this
is an OSX specific thing either.
I have tried this with php4.1.1, 4.1.2, 4.2.0, 4.2.2
The only way I can suppress the errors is to comment out
mod_php in my httpd.conf.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=18725&edit=1