Bug #50203 [Dup]: Apache +mod_php can't load script with non-ASCII name
Edit report at http://bugs.php.net/bug.php?id=50203&edit=1
ID: 50203
Updated by: pajoye@php.net
Reported by: vadim at sukhomlinov dot ru
Summary: Apache +mod_php can't load script with non-ASCII
name
Status: Duplicate
Type: Bug
Package: Apache2 related
Operating System: win32 only - Windows XP SP3
PHP Version: 5.3.0
Block user comment: N
Private report: N
New Comment:
That's only part of the problem, the top of the iceberg.
Previous Comments:
------------------------------------------------------------------------
[2011-03-17 14:22:59] lost dot guadelenn at gmail dot com
Hi pajoye.
Maybe this bug can be fixed without such complex things as Unicode
Filesystem?
(See my comment above - there is api already in both apache and win32)
------------------------------------------------------------------------
[2011-03-17 14:17:45] lost dot guadelenn at gmail dot com
A note to developers:
Apache has api for path manipulation:
http://apr.apache.org/docs/apr/0.9/group__apr__filepath.html
Note function apr_filepath_encoding() which retrieves current path
encoding.
Also note win32 function GetShortPathName() which converts any valid
long pathname to 8.3 ascii format.
------------------------------------------------------------------------
[2011-03-17 14:13:23] pajoye@php.net
There is already a feature request for Unicode Filesystem support. And
no, it is
not implemeneted yet.
------------------------------------------------------------------------
[2011-03-17 14:08:30] lost dot guadelenn at gmail dot com
The bug is still present in php 5.3.5 and apache 2.2.17.
(Both are latest stable versions).
OS is Win7 64 bit (php and apache are 32-bit).
------------------------------------------------------------------------
[2011-01-17 21:58:26] tsanchev at gmail dot com
Directory listing from pache:
Index of /cosmetic-academy
Parent Directory
assets/
pl0_p0_ÐозмеÑик Ðкадеми_html.php
ддадада д аÑд аÑдdasdasd aдаÑÑÑÑ.txt
when try to execute the sctript in the directory i get this error:
Warning: Unknown: failed to open stream: No such file or directory in
Unknown on
line 0
Fatal error: Unknown: Failed opening required 'D:/web/www/cosmetic-
academy/pl0_p0_ÐозмеÑик Ðкадеми_html.php'
(include_path='.;C:\php5\pear') in
Unknown on line 0
if the name contain only ascii chars it works perfectly
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/bug.php?id=50203
--
Edit this bug report at http://bugs.php.net/bug.php?id=50203&edit=1
Thread (7 messages)