Bug #54301 [Com]: phpinfo not working
Edit report at http://bugs.php.net/bug.php?id=54301&edit=1
ID: 54301
Comment by: carsten_sttgt at gmx dot de
Reported by: wapinet at mail dot ru
Summary: phpinfo not working
Status: Bogus
Type: Bug
Package: Reproducible crash
Operating System: Windows XP SP3 32
PHP Version: 5.3.6
Block user comment: N
Private report: N
New Comment:
> I'm reasonably happy to leave this closed,
> even if it does turn out to be another manifestation of bug #54200:
That's ok (isn't a dub not also bogus?). But now I can add this
(zend_extension) to #54200.
> the third party extension is more likely to be at fault.
Always good if a 3rd party extension is involved... ;-)
But I've just tested this: PHP 5.3.6-nts together with ea (5.3.5) is not
crashing. Just a message "ea can't be loaded" or no message with
"display_startup_errors = Off".
BTW: which other problems (then [zend_]extension=) are hidden with
"display_startup_errors = Off"?
Previous Comments:
------------------------------------------------------------------------
[2011-03-18 14:15:34] aharvey@php.net
If PHP crashes with a third party extension, and doesn't crash without
the third party extension, I'm reasonably happy to leave this closed,
even if it does turn out to be another manifestation of bug #54200: on
the evidence in this bug, the third party extension is more likely to
be at fault.
------------------------------------------------------------------------
[2011-03-18 12:50:49] wapinet at mail dot ru
a) I using thread safe version
b) display_startup_errors = On
------------------------------------------------------------------------
[2011-03-18 11:00:26] carsten_sttgt at gmx dot de
@wapinet
Can you tell me:
a) You are using the thread safe or non thread safe version of PHP?
b) What's the value of display_startup_errors?
@aharvey
Even PHP 5.3.6 can't load an eAccelerator build for 5.3.5, there should
no core dump (Access violation). I guess this report is also a dup for
bug #54200.
------------------------------------------------------------------------
[2011-03-18 09:49:53] wapinet at mail dot ru
I apologize. The problem was that eAccelerator has been compiled for php
version 5.3.5
Disable eAccelerator solved the problem.
------------------------------------------------------------------------
[2011-03-18 09:36:55] aharvey@php.net
Is this happening under a Web server or using the CLI version of PHP?
If it's a Web server, what are you getting in the Web server's error
log?
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/bug.php?id=54301
--
Edit this bug report at http://bugs.php.net/bug.php?id=54301&edit=1
Thread (9 messages)