Edit report at https://bugs.php.net/bug.php?id=54488&edit=1
ID: 54488
Comment by: fat@php.net
Reported by: dbetz at df dot eu
Summary: SIGSEGV in zend_assign_to_variable
Status: Assigned
Type: Bug
Package: FPM related
Operating System: Gentoo
PHP Version: 5.3.6
Assigned To: fat
Block user comment: N
Private report: N
New Comment:
I've asked for help on internals: http://news.php.net/php.internals/53922
see where it goes
Previous Comments:
------------------------------------------------------------------------
[2011-07-07 02:38:16] dbetz at df dot eu
Hello,
with 5.3.7RC3-dev i cant hit the bug anymore ( i think )
I will keep on testing.
Thx,
Daniel
------------------------------------------------------------------------
[2011-07-06 08:56:27] dbetz at df dot eu
Ah, what i have forgotten:
With debug flags in the php-fpm binary the segfaults seems not to occur so often.
I try now the latest snapshot to see if the problem is there too.
------------------------------------------------------------------------
[2011-07-06 08:41:50] dbetz at df dot eu
Oh sorry, my failure.
Now its 5.3.6 and the problem still exists with that version.
Greetings,
Daniel
------------------------------------------------------------------------
[2011-07-06 08:32:58] fat@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php
If you can provide more information, feel free to add it
to this bug and change the status back to "Open".
Thank you for your interest in PHP.
you are reporting using 5.3.6 but on the phpinfo() page you provide us it's 5.3.5.
Is it possible for you to test using the last snapshot of 5.3 please ?
thx
++ jerome
------------------------------------------------------------------------
[2011-07-06 07:29:49] dbetz at df dot eu
Hello,
no problem. :-)
The apache config is a little bit difficult, so i only paste the relevant things:
LoadModule fastcgi_module mod_fastcgi.so
LoadModule ldap_module mod_ldap.so
LoadModule vhost_ldap_module mod_vhost_ldap.so
LDAPSharedCacheSize 2000000
LDAPCacheEntries 4096
LDAPCacheTTL 5
LDAPOpCacheEntries 4096
LDAPOpCacheTTL 5
FastCgiExternalServer /etc/httpd/fastcgi/php-fcgi-starter -socket /etc/httpd/fastcgi/php5-53LATEST
Action php-fastcgi /php/php-fcgi-starter
<VirtualHost _default_:80>
ServerName domainname.de
SuexecUserGroup apache nobody
DocumentRoot /kunden/shadow/htdocs/
ScriptAlias /php/ /etc/httpd/fastcgi/
VhostLDAPEnabled on
VhostLDAPUrl "ldap://localhost/cn=bla,sec=hosting,o=domain,c=de"
VhostLdapBindDN "cn=username,cn=bla,sec=hosting,o=domain,c=de"
VhostLDAPBindPassword "noone"
</Virtualhost>
FPM Config:
;;;;;;;;;;;;;;;;;;;;;
; FPM Configuration ;
;;;;;;;;;;;;;;;;;;;;;
; All relative paths in this configuration file are relative to PHP's install
; prefix.
; Include one or more files. If glob(3) exists, it is used to include a bunch of
; files from a glob(3) pattern. This directive can be used everywhere in the
; file.
include=/usr/local/etc/fpm.d/5-53LATEST-*.conf
;;;;;;;;;;;;;;;;;;
; Global Options ;
;;;;;;;;;;;;;;;;;;
[global]
pid = /var/run/php5-53LATEST.pid
; Error log file
; Note: the default prefix is /usr/local/var
; Default Value: log/php-fpm.log
error_log = /var/log/php-fpm.log
; Log level
; Possible Values: alert, error, warning, notice, debug
; Default Value: notice
log_level = warning
; If this number of child processes exit with SIGSEGV or SIGBUS within the time
; interval set by emergency_restart_interval then FPM will restart. A value
; of '0' means 'Off'.
; Default Value: 0
emergency_restart_threshold = 10
[default]
listen = /etc/httpd/fastcgi/5-53LATEST
user = root
group = nobody
pm = dynamic
pm.max_children = 1000
pm.start_servers = 1
pm.min_spare_servers = 1
pm.max_spare_servers = 1
pm.max_requests = 1000
; PHP.ini Settings:
php_flag[track_errors] = Off
php_flag[allow_url_fopen] = On
php_flag[sql.safe_mode] = Off
..
tons of php_(admin)_flags
phpinfo() can be found at http://imageupgrade2.domainfactory-kunde.de/info.php
Thanks for your help
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=54488
--
Edit this bug report at https://bugs.php.net/bug.php?id=54488&edit=1