Bug #44729 [Com]: display_errors = Off not respected
| From: | John dot W dot Stephens at nasa dot gov | Date: | Wed, 13 Jul 2011 19:42:18 +0000 |
| Subject: | Bug #44729 [Com]: display_errors = Off not respected | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-161870@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=44729&edit=1
ID: 44729
Comment by: John dot W dot Stephens at nasa dot gov
Reported by: hsbrown2 at verizon dot net
Summary: display_errors = Off not respected
Status: No Feedback
Type: Bug
Package: PHP options/info functions
Operating System: Windows Server 2008
PHP Version: 5.2.5
Assigned To: fb-req-jani
Block user comment: N
Private report: N
New Comment:
I'm experiencing the same issue as described above. 'display_errors = Off' is
ignored.
I'm running a longtime stable wiki which we just migrated from an XP box to a Server2008 box.
We upgraded from WebDev1 to WebDev2 in the process, which includes PHP5.2.5. When running on the XP
box (3 years), the display_error was honored. On the new Server2008 box, it is ignored.
Previous Comments:
------------------------------------------------------------------------
[2009-01-15 20:24:54] zugg at zuggsoft dot com
I have experienced this same problem with the CentOS 5.2 FCGI version of PHP5. I can use the
error_reporting() function to turn off error reporting, but the display_errors=Off in the PHP.INI
file is ignored otherwise.
------------------------------------------------------------------------
[2008-09-07 08:50:22] php at jamesvalero dot com
I also tried the latest version (PHP Version 5.2.7-dev) with the same results.
It seems this is an error specific to FastCGI. When changing to php5isapi.dll, display_errors works
as expected. When switching to php5-cgi.exe, display_errors still shows errors even when set to Off.
Both versions (5.2.7-dev and 5.2.6) have this problem.
------------------------------------------------------------------------
[2008-09-07 08:28:06] php at jamesvalero dot com
I'm getting the same error with PHP 5.2.6 on Windows 2k3R2STD IIS FastCGI
<?php
phpinfo();
asdf
?>
It shows the standard phpinfo(); output but at the very bottom it has PHP Notice: Use of undefined
constant asdf - assumed 'asdf' in
D:\Domains\itgstats-dev.hottopic.com\public_html\phpinfo.php on line 4
This is what I have for display_errors:
Directive Local Value Master Value
display_errors Off Off
Here's my first segment
System Windows NT CAINTDEV1 5.2 build 3790
Build Date May 2 2008 18:01:20
Configure Command cscript /nologo configure.js "--enable-snapshot-build"
"--with-gd=shared" "--with-extra-includes=C:\Program Files (x86)\Microsoft
SDK\Include;C:\PROGRA~2\MICROS~2\VC98\ATL\INCLUDE;C:\PROGRA~2\MICROS~2\VC98\INCLUDE;C:\PROGRA~2\MICROS~2\VC98\MFC\INCLUDE"
"--with-extra-libs=C:\Program Files (x86)\Microsoft
SDK\Lib;C:\PROGRA~2\MICROS~2\VC98\LIB;C:\PROGRA~2\MICROS~2\VC98\MFC\LIB"
Server API CGI/FastCGI
Virtual Directory Support enabled
Configuration File (php.ini) Path C:\WINDOWS
Loaded Configuration File C:\WINDOWS\php.ini
PHP API 20041225
PHP Extension 20060613
Zend Extension 220060519
Debug Build no
Thread Safety enabled
Zend Memory Manager enabled
IPv6 Support enabled
Registered PHP Streams php, file, data, http, ftp, compress.zlib, zip
Registered Stream Socket Transports tcp, udp
Registered Stream Filters convert.iconv.*, string.rot13, string.toupper, string.tolower,
string.strip_tags, convert.*, consumed, zlib.*
------------------------------------------------------------------------
[2008-05-02 01:00:01] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
------------------------------------------------------------------------
[2008-04-24 10:44:21] jani@php.net
That phpinfo() page is not accessible. Also, put something to cause a notice to appear in the same
script..
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=44729
--
Edit this bug report at https://bugs.php.net/bug.php?id=44729&edit=1