ID: 14193
Comment by: ulf.byskov@comptel.com
Reported By: scalero@datadec.es
Status: Closed
Bug Type: OCI8 related
Operating System: tru64 v.5.1
PHP Version: 4.0.6
New Comment:
I believe this is an Oracle problem (Nothing to do with PHP). I have
tried everything to make this work......with no results. It seems that
Oracle 8.1.7.0 works but problems occurs when using some of the
versions with added patches 8.1.7.3 or higher. In my case the only
viable solution was to downgrade oracle, but if that is not an option
you are stucked until someone comes up with a something better.
Previous Comments:
------------------------------------------------------------------------
[2002-06-11 16:01:53] nilesh@dosooye.com
I also am having the same problem and error message.
Syntax error on line 205 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: dlopen:
/usr/local/apache/libexec/libphp4.so: symbol "OCILobIsTemporary"
unresolved
I tried the solution about adding
#undefine HAVE_OCI8_TEMP_LOB
to the oci8.c
but it still would give the same errors and apache will not start.
I would appreciate any help.
------------------------------------------------------------------------
[2002-04-13 09:00:01] thies@php.net
add
#undefine HAVE_OCI8_TEMP_LOB
to the top of oci8.c and recompile
------------------------------------------------------------------------
[2001-11-23 04:09:58] scalero@datadec.es
NLS_LANG=SPANISH_SPAIN.WE8ISO8859P1
ORACLE_BASE=/u01/app/oracle
ORACLE_PATH=/u01/app/oracle/product/8.1.7/bin
LOGNAME=root
when I compile PHP/4.2.0-dev like DSO in tru64 v.5.1 with the
following variables of surroundings:
************************************************************
TEMPDIR=/u01/temp
ORACLE_SID=dborapre
GWSOURCE=telnet
ORACLE_OWNER=oracle
USER=root
ORACLE_DOC=/u01/app/oracle/product/8.1.7/doc
SHELL=/bin/ksh
ORACLE_TERM=vt220
ORA_NLS33=/u01/app/oracle/product/8.1.7/ocommon/nls/admin/data
HOME=/
LD_LIBRARY_PATH=/u01/app/oracle/product/8.1.7/lib
TERM=vt220
ORACLE_HOME=/u01/app/oracle/product/8.1.7
************************************************************
then I execute:
# ./configure --enable-ftp --with-gettext
--with-imap=/data/sebas/programs/imap-uw --with-oci8
--with-apxs=/usr/opt/IAE550/usr/internet/httpd/bin/apxs
--enable-dependency-tracking
#make
#make install
and when I start Apache:
Cannot load /usr/internet/httpd/libexec/libphp4.so into server: dlopen:
/usr/internet/httpd/libexec/libphp4.so: symbol "OCILobIsTemporary"
unresolved
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=14193&edit=1