Bug #51185 [Com]: Apache won't start after PHP 5.3.1 is installed

From: Date: Thu, 25 Aug 2011 06:24:41 +0000
Subject: Bug #51185 [Com]: Apache won't start after PHP 5.3.1 is installed
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-162918@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=51185&edit=1

 ID:                 51185
 Comment by:         tony dot bedford at live dot co dot uk
 Reported by:        randy at thehiringsurvey dot com
 Summary:            Apache won't start after PHP 5.3.1 is installed
 Status:             Bogus
 Type:               Bug
 Package:            Windows Installer
 Operating System:   Windows 7 (x64)
 PHP Version:        5.3.1
 Block user comment: N
 Private report:     N

 New Comment:

I had the same problem with 5.3.5 on Windows 7 with Apache 2.2. Here's how I fixed 
it. When reinstalling Apache (as it failed to start after installing PHP) I got 
the error 'failed to load php5apache2_2.dll'. That of course was a 
clue. Checking httpd.conf I saw that the PHP installer had not set the PHP ini 
directory correctly (just empty quotes) and the path to the DLL was not added. I 
manually fixed these (I installed PHP to C:\PHP) and everything worked fine.

By the way, based on comments above and elsewhere, I checked the path was set with 
correct case. Everything was in order so that wasn't the problem in this case. 
Hope this helps.


Previous Comments:
------------------------------------------------------------------------
[2010-07-21 21:36:19] smacdav at gmail dot com

You're right, of course. I was just realizing the issue and coming back to comment. That was
silly of me. Sorry.

------------------------------------------------------------------------
[2010-07-21 21:30:27] pajoye@php.net

@smacdav at gmail dot com

Your install is a mess then. php 5.2's sapi dll cannot work nor load with 5.3.

Please ask php-setup or php-windows mailing for further supports (to any other reporters looking for
help regarding the problem described here).

------------------------------------------------------------------------
[2010-07-21 21:26:58] smacdav at gmail dot com

It's not the path variable; it's the dll file. I had exactly the same issue. I made sure
my path had the right case and tried starting Apache: no dice. I had backed up my old php (from PHP
5.2.11) folder before installing PHP 5.3, so I tried copying php5apache2_2.dll from the backed up
folder into the installation folder for PHP 5.3. Bingo! Apache started up and seems to be running
fine. (Haven't tested and PHP 5.3 only features yet, though.)

------------------------------------------------------------------------
[2010-03-16 00:48:07] randy at thehiringsurvey dot com

Two points:
1. I did not have to manually define any PATH variables when I installed PHP 5.2.13 after I had
uninstalled 5.3.1.  So the 5.2.13 installer is working where the 5.3.1 failed.
2. After I got PHP 5.2.13 running I installed PEAR.  I ran into a non-fatal installation problem in
PEAR as well.  I found out that Windows 7 is case sensitive when referring to PATHs.  PEAR was
creating it's PATH variable with the directory in all upper, but the actual folder was all
lower.  That worked on earlier Windows, but not on 7.  I don't know which Windows version they
made that change in.  But once I edited PEAR's PATH variables to match the actual directory
case the non-fatal error was resolved.

I suspect that PHP 5.3.1's installer is creating a path with the wrong case, based upon the
assumption that Windows doesn't care.  Can't prove it without uninstalling PHP, and I
can't do that right now.

------------------------------------------------------------------------
[2010-03-16 00:41:04] pajoye@php.net

@cunobatis at bluewin dot ch

that's a configuration problem. Adding the PHP directory to your PATH is a required step when
you configure PHP with Apache.

------------------------------------------------------------------------


The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at

    https://bugs.php.net/bug.php?id=51185


-- 
Edit this bug report at https://bugs.php.net/bug.php?id=51185&edit=1


Thread (14 messages)

« previous php.bugs (#162918) next »