Bug #15 [Com]: Apache 1.2.4 .htaccess directives
| From: | junxing dot lin at yahoo dot com | Date: | Mon, 29 Aug 2011 08:19:05 +0000 |
| Subject: | Bug #15 [Com]: Apache 1.2.4 .htaccess directives | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-163045@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=15&edit=1
ID: 15
Comment by: junxing dot lin at yahoo dot com
Reported by: walshj at ns dot net
Summary: Apache 1.2.4 .htaccess directives
Status: Closed
Type: Bug
Package: Other
Operating System: Solaris 2.5.1
PHP Version: 3.0b3
Block user comment: N
Private report: N
New Comment:
http://www.chishairstraighteners.net chi flat
iron
http://www.chishairstraighteners.net chi flat
irons
http://www.chishairstraighteners.net chi hair
straightener
http://www.chishairstraighteners.net chi hair
straighteners
Previous Comments:
------------------------------------------------------------------------
[1998-01-30 02:45:11] rasmus
[Jim]
To see a list of which directives may only be included in the *.conf files, run 'grep RSRC_CONF
mod_php3.c'.
If you are having problems with particular directives in your configuration, please open a new bug
with
more specific information about the error being generated (such as the relevant log entries from
your
server's error log). "Error 500" just means there was a server error, and
doesn't give any indication of
what it was.
[Rasmus]
The argument to php3_safe_mode should be either 'on' or 'off' and it
shouldn't core dump. I just tested
with Apache 1.2.6-dev on a Solaris 2.5.1 machine and it works perfectly. The only reason you might
be
seeing a core is if you don't match up PHP's regex library with Apache's. I suggest
using the bundled
library for both. PHP defaults to the bundled library, so you should edit your Apache 1.2.x
Configuration
file and set WANTHSREGEX=yes and then recompile.
------------------------------------------------------------------------
[1998-01-27 15:02:41] walshj at ns dot net
Adding any PHP3 Module directive results in an Error 500. Note: Should safe mode have the capability
of being overridden by .htaccess or should that only be an option in php.ini or srm.conf? Some ISPs
may allow dot files to be uploaded.
Example .htaccess file:
IndexIgnore .htaccess */.??* *~ *# */HEADER* */README*
<Limit GET POST>
order deny,allow
deny from all
allow from all
</Limit>
<Limit PUT DELETE>
order deny,allow
deny from all
</Limit>
AuthName somedomain.com
AuthUserFile /home/goo/blah/_vti_pvt/service.pwd
AuthGroupFile /home/goo/blah/_vti_pvt/service.grp
# -PHP3-
php3_safe_mode 0
php3_include_path /home/goo/blah/media/include
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=15&edit=1