Bug #60048 [Opn->Csd]: sa_len a #define on IRIX
| From: | felipe@php.net | Date: | Thu, 13 Oct 2011 22:49:13 +0000 |
| Subject: | Bug #60048 [Opn->Csd]: sa_len a #define on IRIX | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-164315@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=60048&edit=1
ID: 60048
Updated by: felipe@php.net
Reported by: china at thewrittenword dot com
Summary: sa_len a #define on IRIX
-Status: Open
+Status: Closed
Type: Bug
Package: Sockets related
Operating System: IRIX 6.5
PHP Version: 5.3.8
-Assigned To:
+Assigned To: felipe
Block user comment: N
Private report: N
New Comment:
This bug has been fixed in SVN.
Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
For Windows:
http://windows.php.net/snapshots/
Thank you for the report, and for helping us make PHP better.
Previous Comments:
------------------------------------------------------------------------
[2011-10-13 07:50:48] china at thewrittenword dot com
Description:
------------
<sys/socket.h> on IRIX 6.5 defines sa_len as:
#define sa_len sa_union.sa_generic.sa_len2
Because of this, socket_accept() in ext/sockets/sockets.c cannot be compiled on this platform
because it uses sa_len as a variable:
PHP_FUNCTION(socket_accept)
{
zval *arg1;
php_socket *php_sock, *new_sock;
php_sockaddr_storage sa;
socklen_t sa_len = sizeof(sa);
The obvious fix is to rename "sa_len" to something like php_sa_len.
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=60048&edit=1