#15374 [Fbk]: include_path loses value when executed
| From: | kalowsky@php.net | Date: | Sat, 10 Aug 2002 13:37:24 +0000 |
| Subject: | #15374 [Fbk]: include_path loses value when executed | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-16434@lists.php.net to get a copy of this message | ||
ID: 15374
Updated by: kalowsky@php.net
Reported By: aaron.hawley@uvm.edu
Status: Feedback
Bug Type: PHP options/info functions
Operating System: Solaris 8
PHP Version: 4.2.1
New Comment:
Any chance you can try the non-stable, development branch of this?
Previous Comments:
------------------------------------------------------------------------
[2002-08-08 14:34:48] aaron.hawley@uvm.edu
php4-STABLE-latest.tar.gz > 08-Aug-2002 09:02 3.3M
still appears that the include_path value doesn't get dropped, but it
also doesn't get used.
------------------------------------------------------------------------
[2002-08-08 09:16:18] aaron.hawley@uvm.edu
here is more information on that snapshot we installed; in particular
the requirement of absolute paths. it seems to not drop the
'include_path' information - which is good, but it also doesn't seem to
use the value either.
Warning: main("Class.php") - No such file or directory in
/usr/local/http-data/htdocs/foo/foo.php on line 2
Fatal error: Failed opening required 'Class.php'
(include_path='.:/usr/local/lib/php') in
/usr/local/http-data/htdocs/foo/foo.php on line 2
------------------------------------------------------------------------
[2002-07-19 15:51:25] aaron.hawley@uvm.edu
that snapshot seems to require absolute pathnames, or atleast rejust
relative paths?
i haven't noticed a warning being generated. but this is on our
non-production and "less stressed" test web server.
------------------------------------------------------------------------
[2002-07-16 14:17:59] sniper@php.net
Wierd..never noticed this before. Does it happen with this
snapshot:
http://snaps.php.net/php4-latest.tar.gz
------------------------------------------------------------------------
[2002-07-16 09:28:34] jflemer@php.net
Just as a note. This still happens with:
Apache-1.3.26
PHP-4.2.1
Solaris 8 (SunOS 5.8)
It's fairly infrequent, but still occasionally get:
Warning: Unable to access PEAR.php in foo.php on line 42
Fatal error: Failed opening required 'PEAR.php'
(include_path='') in foo.php on line 42
As Aaron suggested, adding this code fixes it:
ini_set('include_path', ini_get('include_path'));
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/15374
--
Edit this bug report at http://bugs.php.net/?id=15374&edit=1