#18239 [Fbk->Csd]: libphp cannot be loaded. Apache dies with msg missing __cmpdi2

From: Date: Mon, 12 Aug 2002 11:05:40 +0000
Subject: #18239 [Fbk->Csd]: libphp cannot be loaded. Apache dies with msg missing __cmpdi2
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-16537@lists.php.net to get a copy of this message
ID: 18239 User updated by: tasosc@otenet.gr Reported By: tasosc@otenet.gr -Status: Feedback +Status: Closed Bug Type: Compile Failure Operating System: Solaris 2.8 PHP Version: 4.2.1 New Comment: The error message was missing __cmpdi2 gcc version 2.95.2 Adding the '--enable-libgcc' flag to configure solved the problem thanks. Previous Comments: ------------------------------------------------------------------------ [2002-07-09 08:02:27] sniper@php.net Which compiler are you using? Does adding '--enable-libgcc' help? And what is the complete error message you get? ------------------------------------------------------------------------ [2002-07-09 07:15:47] tasosc@otenet.gr PHP version 4.1.2 works with same excact config. gcc was used. Apache version is 1.3.26.+ mod_ssl + EAPI. /usr/apache/bin/httpd -V Server version: Apache/1.3.26 (Unix) Server built: Jul 9 2002 00:46:51 Server's Module Magic Number: 19990320:13 Server compiled with.... -D EAPI -D EAPI_MM -D EAPI_MM_CORE_PATH="/var/run/httpd.mm" -D HAVE_MMAP -D USE_MMAP_SCOREBOARD -D USE_MMAP_FILES -D HAVE_FCNTL_SERIALIZED_ACCEPT -D HAVE_SYSVSEM_SERIALIZED_ACCEPT -D HAVE_PTHREAD_SERIALIZED_ACCEPT -D HTTPD_ROOT="/usr/apache" -D SUEXEC_BIN="/usr/apache/bin/suexec" -D DEFAULT_PIDLOG="/var/run/httpd.pid" -D DEFAULT_SCOREBOARD="/var/run/httpd.scoreboard" -D DEFAULT_LOCKFILE="/var/run/httpd.lock" -D DEFAULT_ERRORLOG="/var/apache/logs/error_log" -D TYPES_CONFIG_FILE="/etc/apache/mime.types" -D SERVER_CONFIG_FILE="/etc/apache/httpd.conf" -D ACCESS_CONFIG_FILE="/etc/apache/access.conf" -D RESOURCE_CONFIG_FILE="/etc/apache/srm.conf" PHP configured : './configure' '--with-zlib' '--with-apxs=/usr/apache/bin/apxs' '--enable-safe-mode' '--with-gdbm' '--with-mysql=/usr/local/mysql' '--enable-trans-sid' '--with-imap=../imap' '-enable-magic-quotes' ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=18239&edit=1

« previous php.bugs (#16537) next »