Bug #60462 [Com]: When APC is enabled segfault
| From: | henrik at bjrnskov dot dk | Date: | Wed, 28 Dec 2011 15:50:26 +0000 |
| Subject: | Bug #60462 [Com]: When APC is enabled segfault | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-166119@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=60462&edit=1
ID: 60462
Comment by: henrik at bjrnskov dot dk
Reported by: henrik at bjrnskov dot dk
Summary: When APC is enabled segfault
Status: Open
Type: Bug
Package: FPM related
Operating System: Mac OS X 10.7
PHP Version: 5.4.0RC2
Block user comment: N
Private report: N
New Comment:
Just tried compiling a 5.4RC4 manually and installing apc from svn and pecl.
both php-fpm and apache2 module segfaults.
OS X Lion 10.7.3
Previous Comments:
------------------------------------------------------------------------
[2011-12-17 11:14:35] lolautruche at gmail dot com
Here : http://svn.php.net/repository/pecl/apc/
------------------------------------------------------------------------
[2011-12-17 11:10:53] henrik at bjrnskov dot dk
Where is apc svn ?
------------------------------------------------------------------------
[2011-12-16 17:55:26] lolautruche at gmail dot com
no more segfault with latest php 5.4 build and APC built from trunk
------------------------------------------------------------------------
[2011-12-16 17:34:04] lolautruche at gmail dot com
Hi
I also experience this issue on Linux Ubuntu Server 8.04 LTS
------------------------------------------------------------------------
[2011-12-07 20:25:55] henrik at bjrnskov dot dk
Description:
------------
[master][~/Projects/Test] /usr/local/php5/sbin/php-fpm -i | ack 'error_log'
error_log => /usr/local/php5/var/log/php_errors.log =>
/usr/local/php5/var/log/php_errors.log
php-fpm(30748) malloc: *** error for object 0x10122b890: pointer being freed was
not allocated
*** set a breakpoint in malloc_error_break to debug
zsh: abort /usr/local/php5/sbin/php-fpm -i |
zsh: done ack 'error_log'
This also happens when using the built in server and when using the apache module
when APC is enabled.
[APC]
apc.enabled = off
and the issue stops. php-osx.liip.ch is where the php version is installed from.
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=60462&edit=1