Bug #47279 [Com]: Symbol xmlTextReaderSetup definition was not found
Edit report at https://bugs.php.net/bug.php?id=47279&edit=1
ID: 47279
Comment by: junkyork at hotmail dot com
Reported by: johntmills at yahoo dot com
Summary: Symbol xmlTextReaderSetup definition was not found
Status: Bogus
Type: Bug
Package: Apache2 related
Operating System: AIX537
PHP Version: 5.2.8
Block user comment: N
Private report: N
New Comment:
Running IHS on AIX 5.3 and ran into errors loading the modules/libphp5.so file.
I found the best way of handling it was simply to load the libxml2.so.2 in the httpd.conf file
before the loading of the php module: LoadFile /usr/installs/libxml2-2.6.30/.libs/libxml2.so.2
My error:
Syntax error on line 212 of /../../httpd.conf:
Cannot load /../../modules/libphp5.so into server: rtld: 0712-001 Symbol htmlDocDumpMemoryFormat was
referenced\n from modul
e /../../modules/libphp5.so(), but a runtime definition\n of the symbol was not found.\nrtld:
0712-001 Symbol xmlTextReaderS
etup was referenced\n from module /../../modules/libphp5.so(), but a runtime definition\n
of the symbol was not found.
Previous Comments:
------------------------------------------------------------------------
[2011-02-07 19:32:27] phil dot nyc at gmail dot com
Had a similar problem on AIX 5.3
PHP compiled (after a day or so of work massaging the various discrepit pieces
of AIX, including math.h ...) but wouldn't run with the above xmlTextReaderSetup
error.
After I updated libxml2, it worked fine. (Googling around says php now needs
libxml 2.6 or later)
So: get libxml http://www.perzl.org/aix/index.php?n=Main.Libxml2
(I got 2.7.8
and zlib 1.2.5) and run rpm -Uhv file.rpm on those, and your php binary should
now work.
------------------------------------------------------------------------
[2010-09-01 20:19:12] johntmills at yahoo dot com
./configure --with-apxs2=/apps/apache/httpd-2.2.4/bin/apxs --with-libxml-dir=/opt/libxml2/2.6.30
--with-mysql=/opt/mysql/5.0.67 --with-config-file-path=/apps/apache/conf --enable-maintainer-zts
--prefix=/opt/php/5.2.8 --enable-sigchild --with-oci8=/oracle/app/oracle/product/10.2.0
make -i install
cp .libs/libphp5.a /apps/IBMIHS/modules/libphp5.a
cp .libs/libphp5.lai /apps/IBMIHS/modules/libphp5.la
cp -p .libs/libphp5.so /apps/IBMIHS/modules/libphp5.so
chmod 755 /apps/IBMIHS/modules/libphp5.so
libtool --finish /mnt/php/5.2.8/php-5.2.8_webcomm_aix53_src/libs
cd / ; tar -cvf /mnt/php/5.2.8/php-5.2.8_webcomm_aix53.tar ./opt/php ./apps/IBMIHS/modules/libphp*
./apps/IBMIHS/conf/php.ini ; cd -
cp -p ./.libs/libphp5.so /apps/apache/httpd-2.2.4/modules/libphp5.so
chmod 755 /apps/apache/httpd-2.2.4/modules/libphp5.so
libtool --finish /export/packages/php-5.2.8_aix53_src/libs
rc.httpd details:
start_httpd()
{
echo "Starting HTTPD..."
PID=cat /apps/apache/logs/httpd.pid 2>/dev/null
if ps -ef | grep httpd | grep -v grep | awk {'print "_" $2
"_"'} | grep "_${PID}_" 1>/dev/null 2>/dev/null
then
echo "HTTPD is already running..."
else
PRELIB=$LIBPATH
LIBPATH=/apps/apache/httpd-2.2.4/lib:/opt/libxml2/2.6.30/lib
export LIBPATH
/apps/apache/httpd-2.2.4/bin/apachectl start
LIBPATH=$PRELIB
export LIBPATH
fi
}
stop_httpd()
{
# stop daemon
echo "Stopping HTTPD..."
PID=cat /apps/apache/logs/httpd.pid 2>/dev/null
if ps -ef | grep httpd | grep -v grep | awk {'print "_" $2
"_"'} | grep "_${PID}_" 1>/dev/null 2>/dev/null
then
PRELIB=$LIBPATH
LIBPATH=/apps/apache/httpd-2.2.4/lib:/opt/libxml2/2.6.30/lib
export LIBPATH
/apps/apache/httpd-2.2.4/bin/apachectl stop
LIBPATH=$PRELIB
export LIBPATH
else
echo "HTTPD is not running..."
fi
------------------------------------------------------------------------
[2010-08-27 05:49:11] johntmills at yahoo dot com
Ah well that never really worked. What I did was make install with an ignore errors flag, than
manually moved the files where they needed to be to prepare for use. I'll grab my procedure
for IBM VAC in the morning and post it.
------------------------------------------------------------------------
[2010-08-25 15:55:46] rodri dot martins at gmail dot com
I'm getting the same error you in the installation of PHP on AIX 5.3. Can you help?
------------------------------------------------------------------------
[2010-08-25 15:54:01] rodri dot martins at gmail dot com
# gmake -k install
Installing PHP SAPI module: apache2handler
/usr/local/buildforge/apache/build/instdso.sh
SH_LIBTOOL='/usr/local/buildforge/apache/build/libtool' libphp5.la
/usr/local/buildforge/apache/modules
rm -f /usr/local/buildforge/apache/modules/libphp5.so
/usr/local/buildforge/apache/build/libtool --mode=install cp libphp5.la
/usr/local/buildforge/apache/modules/
cp .libs/libphp5.a /usr/local/buildforge/apache/modules/libphp5.a
cp .libs/libphp5.lai /usr/local/buildforge/apache/modules/libphp5.la
libtool: install: warning: remember to run `libtool --finish /install/update/php-5.2.6/libs'
chmod 755 /usr/local/buildforge/apache/modules/libphp5.so
chmod: /usr/local/buildforge/apache/modules/libphp5.so: A file or directory in the path name does
not exist.
apxs:Error: Command failed with rc=65536
.
gmake: *** [install-sapi] Error 1
Installing PHP CLI binary: /usr/local/buildforge/php/bin/
Installing PHP CLI man page: /usr/local/buildforge/php/man/man1/
Installing shared extensions:
/usr/local/buildforge/php/lib/php/extensions/no-debug-non-zts-20060613/
Installing build environment: /usr/local/buildforge/php/lib/php/build/
Installing header files: /usr/local/buildforge/php/include/php/
Installing helper programs: /usr/local/buildforge/php/bin/
program: phpize
program: php-config
Installing man pages: /usr/local/buildforge/php/man/man1/
page: phpize.1
page: php-config.1
Installing PEAR environment: /usr/local/buildforge/php/lib/php/
[PEAR] PEAR - already installed: 1.7.1
Wrote PEAR system config file at: /usr/local/buildforge/php/etc/pear.conf
You may want to add: /usr/local/buildforge/php/lib/php to your php.ini include_path
Installing PDO headers: /usr/local/buildforge/php/include/php/ext/pdo/
gmake: Target `install' not remade because of errors.
# cp .libs/libphp5.a /usr/local/buildforge/apache/modules/libphp5.a
# cp .libs/libphp5.lai /usr/local/buildforge/apache/modules/libphp5.la
# cp .libs/libphp5.so /usr/local/buildforge/apache/modules/libphp5.so
# chmod 755 /usr/local/buildforge/apache/modules/libphp5.so
# chmod 755 /usr/local/buildforge/apache/modules/libphp5.la
# chmod 755 /usr/local/buildforge/apache/modules/libphp5.a
# /usr/local/buildforge/apache/bin/apachectl start
httpd: Syntax error on line 55 of /usr/local/buildforge/apache/conf/httpd.conf: Cannot load
/usr/local/buildforge/apache/modules/libphp5.so into server: rtld: 0712-001 Symbol
xmlTextReaderSetup was referenced\n from module
/usr/local/buildforge/apache/modules/libphp5.so(), but a runtime definition\n of the symbol was
not found.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=47279
--
Edit this bug report at https://bugs.php.net/bug.php?id=47279&edit=1
Thread (10 messages)