Bug #47178 [Fbk->]: Missing gzip headers in gzencode() output
| From: | mike@php.net | Date: | Wed, 18 Jan 2012 17:13:57 +0000 |
| Subject: | Bug #47178 [Fbk->]: Missing gzip headers in gzencode() output | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-166588@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=47178&edit=1
ID: 47178
Updated by: mike@php.net
Reported by: wharmby at uk dot ibm dot com
Summary: Missing gzip headers in gzencode() output
-Status: Feedback
+Status: To be documented
Type: Bug
Package: Zlib related
Operating System: Windows XP
PHP Version: 5.4
Assigned To: mike
Block user comment: N
Private report: N
New Comment:
This bug has been fixed in SVN.
Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
Thank you for the report, and for helping us make PHP better.
I removed the XFAIL now, and added a note to the UPDGRADE guide.
Previous Comments:
------------------------------------------------------------------------
[2011-09-30 06:51:46] mike@php.net
So can this ticket be changed to closed? The code will be released with PHP-
5.4...
------------------------------------------------------------------------
[2010-05-31 15:23:27] mike@php.net
So? This code went into trunk now.
------------------------------------------------------------------------
[2009-03-03 22:11:13] mike@php.net
Hi Andy!
Sorry for the standard-bla of the quick fix in my previos response.
Interestingly, gzencode(..., FORCE_DEFLATE) does not make any sense to me in PHP versions lower than
v6. I cannot remember why or even if I noticed this legacy behaviour back when I reimplemented zlib
code.
For clarification:
RFC1951 = raw deflate
- not much to say here
RFC1950 = zlib encoding, AKA HTTP deflate;
- being [zlib header][deflated data][adler checksum]
RFC1952 = gzip encoding
- being [gzip header][deflated data][crc32 checksum, original size]
The output of PHP5s gzencode(..., FORCE_DEFLATE) is neither of the previous formats, but rather zlib
encoded data additionally prepended with a gzip header:
[gzip header][zlib header][deflated data][adler checksum]
This is obscure IMHO.
Obviously, this exists and is even documented for ages, so I kindly ask you to take this issue to
internals@ for discussion, so people can decide what's going to happen.
Thank you.
------------------------------------------------------------------------
[2009-03-02 11:01:28] wharmby@php.net
Hi Mike
If you think the bug lies in php5 can you re-assign to that release please. I will fix the PHPT
accordingly
Regards
Andy
------------------------------------------------------------------------
[2009-03-02 10:50:14] wharmby at uk dot ibm dot com
Hi Mike
Can you expand on your reason for closing this defect as bogus a little more please given
that:
(1) The same test produces different results on php 5.2 and 5.3,
i.e the output from gzencode() with FORCE_DEFLATE includes the zlib
headers in both cases.
(2) The PHP manual says for the gzencode() option 'encoding mode'
"If you use FORCE_DEFLATE, you get a standard zlib deflated
string (inclusive zlib headers) after the gzip file header
but without the trailing crc32 checksum. "
This suggests that the output should include zlib headers.
So if the PHP 6 behaviour is correct does this not mean there is a
bug in both PHP 5 code and description of the command in the PHP
manual ? I raised the bug against PHP 6 as its behaviour differed to
previous releases and I assumed it was a bug in the new zlib code
but if the bug lies in PHP % I am happy to fix up the new PHPT's and open a defect against PHP
5.
Regards
Andy
Andy Wharmby
E-mail: andy_wharmby@uk.ibm.com
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=47178
--
Edit this bug report at https://bugs.php.net/bug.php?id=47178&edit=1