Edit report at https://bugs.php.net/bug.php?id=51860&edit=1
ID: 51860
Updated by: rasmus@php.net
Reported by: stephan dot suerken at 1und1 dot de
Summary: Include fails with toplevel symlink to /
Status: Feedback
Type: Bug
Package: Scripting Engine problem
PHP Version: 5.3.2
Block user comment: N
Private report: N
New Comment:
Never mind, I see it now.
% php phptest/phpinc
OK
But
% php /phptest/phpinc
Warning: include(/phptest/phpfile): failed to open stream: No such file or
directory in /phpinc on line 2
Warning: include(): Failed opening '/phptest/phpfile' for inclusion
(include_path='.:/usr/local/lib/php') in /phpinc on line 2
Previous Comments:
------------------------------------------------------------------------
[2012-01-28 18:44:05] rasmus@php.net
I am unable to reproduce this with current PHP versions.
Here is what I did:
% cd /
% ln -s / phptest
% echo "OK" > /phpfile
% echo '<?php include "/phptest/phpfile";' > /phpinc
% /home/rasmus/php-src/branches/PHP_5_4/sapi/cli/php phpinc
OK
% /home/rasmus/php-src/branches/PHP_5_3/sapi/cli/php phpinc
OK
% php phpinc
OK
% cd /phptest
% php phpinc
OK
What am I missing? This seems to be exactly the setup that thekid described.
------------------------------------------------------------------------
[2012-01-28 13:39:24] grobmeier at gmail dot com
I can only agree with startup09. Please fix it. Thousands 1&1 (among others)
customers are using old PHP because of this one. It is going to have birthday
soon. I cannot upgrade my Open Source projects because 5.2 ist sill used on so
many hosts. You need to get this done if you really have an interest your users
migrate to 5.3.
------------------------------------------------------------------------
[2012-01-17 14:51:40] startup09 at web dot de
please fix this! 1&1 still uses 5.2 for all customers because of this bug.
I'm one of these poor people and can't use newer extensions which require 5.3 :(
------------------------------------------------------------------------
[2011-07-06 10:36:49] rainer at hosting-ist-mein-leben dot de
In latest 5.4.0-alpha1 problem is still there.
------------------------------------------------------------------------
[2011-01-21 10:34:00] plubber at gmx dot ch
no solution?
I have the same problem with mounted NFS
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=51860--
Edit this bug report at https://bugs.php.net/bug.php?id=51860&edit=1