Bug #61156 [NEW]: Segfault when using get_defined_constants(true)
| From: | damien at overeem dot org | Date: | Tue, 21 Feb 2012 16:08:28 +0000 |
| Subject: | Bug #61156 [NEW]: Segfault when using get_defined_constants(true) | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-167703@lists.php.net to get a copy of this message | ||
From:
Operating system: openSUSE 11.4
PHP version: Irrelevant
Package: Reproducible crash
Bug Type: Bug
Bug description:Segfault when using get_defined_constants(true)
Description:
------------
ATTN: This is a bug in php verison 5.3.5 !!
I do realize that this is about an earlier version, but I have no available
environments on which i could simply upgrade. So consider this bug report
as a
notification. It can be closed if not considered a valid report. We
resolved our
issue by circumventing use of the categorization of get_defined_constants.
The function get_defined_constants(true) causes a client segfault ([Tue Feb
21
16:18:24 2012] [notice] child pid 12564 exit signal Segmentation fault
(11))
There are some references to this issue occurring ie. #51788. In that
particular
case however, the issue seemed to have been caused by suhosin.
My installation is running native php2 engine v2.3.0.
When using get_defined_constants() (without the categorization parameter)
there
is no problem.
Further information:
OS: openSUSE 11.4
Kernel: 2.6.37.6-0.11-default
Apache version: 2.2.17 ( API Version 20051115)
PHP Version: 5.3.5
Loaded modules:
core prefork http_core mod_so mod_unique_id mod_actions mod_alias
mod_auth_basic
mod_authn_file mod_authz_host mod_authz_groupfile mod_authz_default
mod_authz_user mod_authn_dbm mod_autoindex mod_cgi mod_dir mod_env
mod_expires
mod_include mod_log_config mod_mime mod_negotiation mod_setenvif mod_ssl
mod_status mod_suexec mod_userdir mod_vhost_alias mod_rewrite mod_php5
mod_info
mod_dav mod_deflate mod_proxy mod_proxy_http
Test script:
---------------
<?php
get_defined_constants(true);
?>
Expected result:
----------------
No output, no error logging.
Actual result:
--------------
Output:
Error 324 (net::ERR_EMPTY_RESPONSE): The server closed the connection
without
sending any data.
Apache error log:
[Tue Feb 21 16:18:24 2012] [notice] child pid 12564 exit signal
Segmentation fault
(11)
--
Edit bug report at https://bugs.php.net/bug.php?id=61156&edit=1
--
Try a snapshot (PHP 5.4): https://bugs.php.net/fix.php?id=61156&r=trysnapshot54
Try a snapshot (PHP 5.3): https://bugs.php.net/fix.php?id=61156&r=trysnapshot53
Try a snapshot (trunk): https://bugs.php.net/fix.php?id=61156&r=trysnapshottrunk
Fixed in SVN: https://bugs.php.net/fix.php?id=61156&r=fixed
Fixed in SVN and need be documented: https://bugs.php.net/fix.php?id=61156&r=needdocs
Fixed in release: https://bugs.php.net/fix.php?id=61156&r=alreadyfixed
Need backtrace: https://bugs.php.net/fix.php?id=61156&r=needtrace
Need Reproduce Script: https://bugs.php.net/fix.php?id=61156&r=needscript
Try newer version: https://bugs.php.net/fix.php?id=61156&r=oldversion
Not developer issue: https://bugs.php.net/fix.php?id=61156&r=support
Expected behavior: https://bugs.php.net/fix.php?id=61156&r=notwrong
Not enough info: https://bugs.php.net/fix.php?id=61156&r=notenoughinfo
Submitted twice: https://bugs.php.net/fix.php?id=61156&r=submittedtwice
register_globals: https://bugs.php.net/fix.php?id=61156&r=globals
PHP 4 support discontinued: https://bugs.php.net/fix.php?id=61156&r=php4
Daylight Savings: https://bugs.php.net/fix.php?id=61156&r=dst
IIS Stability: https://bugs.php.net/fix.php?id=61156&r=isapi
Install GNU Sed: https://bugs.php.net/fix.php?id=61156&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=61156&r=float
No Zend Extensions: https://bugs.php.net/fix.php?id=61156&r=nozend
MySQL Configuration Error: https://bugs.php.net/fix.php?id=61156&r=mysqlcfg