Bug #61223 [Opn->Fbk]: php can run oci,but php-fpm oci error
| From: | sixd@php.net | Date: | Fri, 02 Mar 2012 19:32:15 +0000 |
| Subject: | Bug #61223 [Opn->Fbk]: php can run oci,but php-fpm oci error | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-168045@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=61223&edit=1
ID: 61223
Updated by: sixd@php.net
Reported by: 4yuinfo at gmail dot com
Summary: php can run oci,but php-fpm oci error
-Status: Open
+Status: Feedback
Type: Bug
Package: OCI8 related
Operating System: CentOS 6.2
PHP Version: 5.3.10
Block user comment: N
Private report: N
New Comment:
Do non-Oracle apps work? The 502 isn't obviously going to be caused by an
Oracle problem.
Add error checking on the the oci_connect call and see what message is being
passed.
What configuration options did you use?
What Oracle client did you use?
What Oracle environment variables have you set?
How/where did you set the variables?
What is your fpm configuration?
Previous Comments:
------------------------------------------------------------------------
[2012-03-01 16:45:46] 4yuinfo at gmail dot com
Description:
------------
update php 5.3.5 to php 5.3.10
php-fpm oci can't run
Test script:
---------------
cat a.php
---------------------------------------------------------
<?php
print oci_connect('login_id', 'login_pw', 'oracle_db');
---------------------------------------------------------
#command line
php -q a.php
Resource id #5
#nginx+php-fpm
502 bad gateway
#apache + perfork
Resource id #3
Expected result:
----------------
oci8 run to php-fpm can work
Actual result:
--------------
oci8 run to php-fpm can't work
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=61223&edit=1