Bug #61276 [Nab]: OpenSSL old version
Edit report at https://bugs.php.net/bug.php?id=61276&edit=1
ID: 61276
User updated by: frenky dot pv at atlas dot cz
Reported by: frenky dot pv at atlas dot cz
Summary: OpenSSL old version
Status: Not a bug
Type: Bug
Package: *Network Functions
Operating System: Win 2k3 IIS 6
PHP Version: 5.4.0
Block user comment: N
Private report: N
New Comment:
I use version 0.9.8.20 OPENSSL.
The problem has been solved:
When using curl CURLOPT_SSLVERSION must be set to 3
All this works.
Previous Comments:
------------------------------------------------------------------------
[2012-03-05 18:44:46] pajoye@php.net
Please use the 0.9.x version of openssl.
With IIS you can use fastcgi and PHP's own DLLs.
------------------------------------------------------------------------
[2012-03-04 18:06:27] frenky dot pv at atlas dot cz
Description:
------------
file(): SSL operation failed with code 1. OpenSSL Error messages:
error:14077458:SSL routines:SSL23_GET_SERVER_HELLO:reason(1112) in C:\Inetpub\KC\class\tab_card.php
at line 1452
file(): Failed to enable crypto in C:\Inetpub\KC\class\tab_card.php at line 1452
file(https://.../resetpwd.jsp...): failed to open stream: operation failed in
C:\Inetpub\...\tab_card.php at line 1452
PHP 5.4 old verse contains the OpenSSL functions that the file has a problem with loading the https
site, where the version used 1.0.0.x. When you replace the files libeay32.dll and libssl32.dll
version 0.9.8.20 for 1.0.0.7 and PHP (fastcgi) becomes unstable and causes HTTP error 500 (internal
error).
Test script:
---------------
$url = 'http://...';
$out = file( $url );
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=61276&edit=1
Thread (4 messages)