Edit report at https://bugs.php.net/bug.php?id=11062&edit=1
ID: 11062
Comment by: techyvme at gmail dot com
Reported by: rkenny at mke dot catalystwms dot com
Summary: Sharing Violation Error Message
Status: Closed
Type: Bug
Package: Directory function related
Operating System: NT 4.0 SP6a
PHP Version: 4.0.6
Block user comment: N
Private report: N
New Comment:
Hi Guys, just to update you, finally I found a way to solve it
Do you have error messages?, like :
* Path too long
* Error cannot delete file: cannot read from source file or disk
* Cannot delete file: Access is denied
* There has been a sharing violation.
* Cannot delete file or folder The file name you specified is not valid or too long. Specify a
different file name.
For that I tried it with: http://longpathtool.com/
LEEROY
Previous Comments:
------------------------------------------------------------------------
[2002-02-21 12:23:56] jean-marc_andre at hp dot com
Hi,
I have the same problem. I think it may come from rewinddir.
I've written a script that first checks is there is at least one file in a given directory.
It opens the directory and stores the directory handle into a variable.
Further in the same page, the script uses this handle again to gets informations on the files in the
directory, so I use rewinddir on it. Then, the function rewind the directory handle but a new one
appears (I cheched it with nthandle)
Here is a script that I think produces the same effect:
<?php
$hDir=opendir('c:\web\project1\docs\BCD\Status');
if($hDir){
for($i=0;$i<10;$i++){
while(($file=readdir($hDir))!==false){
echo "$file<br>\n";
}
rewinddir($hDir);
}
closedir($hDir);
}
?>
then there are still 10 opened handles
------------------------------------------------------------------------
[2001-11-10 08:43:37] sander@php.net
No feedback. Closing.
------------------------------------------------------------------------
[2001-10-20 20:54:51] sniper@php.net
Is this solved by updating IIS ?
------------------------------------------------------------------------
[2001-07-21 18:22:06] andy@php.net
Make sure Windows or any other app has this directory or any
files in it locked (using them.)
------------------------------------------------------------------------
[2001-07-03 11:38:02] rkenny at mke dot catalystwms dot com
Yes, the purpose of the script is to display the contents of a directory and make them available via
the IIS server. Unfortunately, I need to make use of the NT security model, so switching to apache
is not an option (or I would have, a long time ago). Do you know if this IIS bug was fixed in IIS
5?
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=11062--
Edit this bug report at https://bugs.php.net/bug.php?id=11062&edit=1