Bug #60761 [Com]: zlib.output_compression fails on refresh
| From: | adunar at gmail dot com | Date: | Sat, 14 Apr 2012 23:56:24 +0000 |
| Subject: | Bug #60761 [Com]: zlib.output_compression fails on refresh | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-169601@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=60761&edit=1
ID: 60761
Comment by: adunar at gmail dot com
Reported by: valentiny510 at yahoo dot es
Summary: zlib.output_compression fails on refresh
Status: Assigned
Type: Bug
Package: *Compression related
Operating System: xp
PHP Version: 5.4.0RC5
Assigned To: mattficken
Block user comment: N
Private report: N
New Comment:
I am experiencing the same problem, using PHP 5.4.0 with the PHP-FPM
SAPI on Ubuntu.
zlib appears to only compress the output for the first request from
a particular worker process.
With the default settings it takes a few refreshes to run into the bug.
To reproduce immediately, set pm.start_servers = 1 in php-fpm.conf.
Afterwards, running "/etc/init.d/php5-fpm reload" allows another
request to be compressed before it stops working again.
Previous Comments:
------------------------------------------------------------------------
[2012-04-09 12:50:09] pajoye@php.net
Matt, please take a look at this bug.
------------------------------------------------------------------------
[2012-03-29 04:23:46] ab@php.net
Automatic comment on behalf of ab
Revision: http://git.php.net/?p=php-src.git;a=commit;h=bcfcfb2fc5f358ebfdc76a773b20b3fc056b20c0
Log: Fix bug #61519 test fails, should pass - ext/zlib/tests/bug60761.phpt
------------------------------------------------------------------------
[2012-03-27 16:26:35] ab@php.net
Automatic comment on behalf of ab
Revision: http://git.php.net/?p=php-src.git;a=commit;h=bcfcfb2fc5f358ebfdc76a773b20b3fc056b20c0
Log: Fix bug #61519 test fails, should pass - ext/zlib/tests/bug60761.phpt
------------------------------------------------------------------------
[2012-03-16 09:28:32] mike@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
------------------------------------------------------------------------
[2012-01-17 10:38:30] mike@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php
If you can provide more information, feel free to add it
to this bug and change the status back to "Open".
Thank you for your interest in PHP.
Works fine here, tried with 5.4 and trunk (TS, debug) as mod_php on Apache 2.2.21
worker.
Pierre, could you verify? ... just because the reporter apparently uses Widnows
XP.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=60761
--
Edit this bug report at https://bugs.php.net/bug.php?id=60761&edit=1