#13174 [Opn->Dup]: SIGABRT when starting iPlanet
| From: | kalowsky@php.net | Date: | Sat, 17 Aug 2002 06:12:53 +0000 |
| Subject: | #13174 [Opn->Dup]: SIGABRT when starting iPlanet | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-17105@lists.php.net to get a copy of this message | ||
ID: 13174
Updated by: kalowsky@php.net
Reported By: aki.hakkila@sonera.com
-Status: Open
+Status: Duplicate
Bug Type: iPlanet related
Operating System: Solaris 2.6
PHP Version: 4.0.6
New Comment:
Dup of 10821
Previous Comments:
------------------------------------------------------------------------
[2002-07-26 13:22:41] lbalbalba@hotmail.com
Ive experienced almost exactly the same problem on AIX 4.3.3/iPlanet
4.x when I compile as an nsapi module. Note that PHP works quite nicely
on AIX when compiled as an CGI executable, or when compiled as an
Apache 1.3.x. DSO module. On Linux though, with the *exact* same
iPlanet and PHP versions, things actually work as expected when built
as an nsapi module. See also Bug-15439 for more details.
------------------------------------------------------------------------
[2001-09-17 00:47:31] aki.hakkila@sonera.com
: php4-200109062235 seems to work. Still getting funny error messages
when requesting
: non-existant php script.
:
: Warning: Failed opening '/path/to/document/root/somescript.php' for
inclusion
: (include_path='.:/usr/local/lib/php') in Unknown on line 0
I still get these error messages.
------------------------------------------------------------------------
[2001-09-15 17:12:42] sniper@php.net
So are there any problems with the latest snapshot or not?
------------------------------------------------------------------------
[2001-09-10 05:28:31] aki.hakkila@sonera.com
Oops, sorry ignore the last comment about setting status and headers..
The correct procedure seems to be in sapi_nsapi_send_headers.
------------------------------------------------------------------------
[2001-09-10 05:11:29] aki.hakkila@sonera.com
iPlanet 4.1
php4-200109062235 seems to work. Still getting funny error messages
when requesting
non-existant php script.
Warning: Failed opening '/path/to/document/root/somescript.php' for
inclusion (include_path='.:/usr/local/lib/php') in Unknown on line 0
I suppose iPlanet expects the Service SAF to handle errors (ie. setting
http status). Seems to me that
the NSAPI module should first call protocol_status with correct status
code, then protocol_start_response and
then write any data and return correct result code (which in case of
Not Found error, for example, should be REQ_ABORTED instead of
REQ_EXIT, IMHO).
http://docs.iplanet.com/docs/manuals/enterprise/41/nsapi/04_mysaf.htm#14969
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/13174
--
Edit this bug report at http://bugs.php.net/?id=13174&edit=1