#10821 [Opn->Fbk]: Web server won't start after php make install
| From: | kalowsky@php.net | Date: | Sat, 17 Aug 2002 14:12:44 +0000 |
| Subject: | #10821 [Opn->Fbk]: Web server won't start after php make install | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-17125@lists.php.net to get a copy of this message | ||
ID: 10821
Updated by: kalowsky@php.net
Reported By: eggrant@aol.com
-Status: Open
+Status: Feedback
Bug Type: iPlanet related
Operating System: Solaris 2.7 & Solaris 2.8
PHP Version: 4.0.5
New Comment:
Found as a solution to this problem in another bug report:
ian@ians.net says:
<quote>
i finally found it, i was missing the following line in magnus.conf:
Init fn="php4_init" LateInit="yes"
</quote>
Does this solve your problem any?
Previous Comments:
------------------------------------------------------------------------
[2001-05-11 18:36:37] eggrant@aol.com
I am trying to configure PHP4 to be used with Netscape Enterprise 3.6
with NSAPI, LDAP, and SYBASE-CT on a Solaris 2.7 machine.
The error from the NES admin tool is
pclose() failed. (2: unknown early startup error)
Error
An error occurred during startup.
The server https-<server> was not started.
PHP4.0.5 compile is successfull with the following configuration:
./configure --with-nsapi=/opt/netscape/suitspot
--with-ldap=/usr/local/ldap --with-sybase=/usr/syb119/11.1.1
--enable-track-vars --enable-libgcc
I have completed the PHP4 install steps mentioned on:
http://www.php.net/manual/en/install.netscape-enterprise.ph
I have verified clean tests from the Netscape bug report with Netscape
Engineers:
http://help.netscape.com/kb/corporate/19990524-10.html
If I comment out the following line from the obj.conf file the server
will start as expected.
Init fn="load-modules"
funcs="php4_init,php4_close,php4_execute,php4_auth_tr
ans" shlib="/opt/netscape/suitspot/bin/libphp4.so"
My previous PHP install without the LDAP and Sybase extensions worked
just fine. Problem is that I need the LDAP and Sybase modules.
I have attempted this with Solaris 2.8 and iPlanet Webserver 4.1 SP7
with the same problems.
Anyone have any ideas?
Take Care,
Eric G. Grant
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=10821&edit=1