Bug #62771 [Com]: Compiling with Imap-2007f is failed
| From: | gencer at cmail dot cm | Date: | Sun, 19 Aug 2012 10:24:50 +0000 |
| Subject: | Bug #62771 [Com]: Compiling with Imap-2007f is failed | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-172686@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=62771&edit=1
ID: 62771
Comment by: gencer at cmail dot cm
Reported by: gencer at cmail dot cm
Summary: Compiling with Imap-2007f is failed
Status: Open
Type: Bug
Package: Compile Failure
Operating System: CentOS 6.3
PHP Version: 5.4.5
Block user comment: N
Private report: N
New Comment:
Hi,
Issue resolved. It seems PHP 5.4.6 has this fix. I am able to install with IMAP feature
successfully.
Gencer.
Previous Comments:
------------------------------------------------------------------------
[2012-08-07 17:51:31] gencer at cmail dot cm
Description:
------------
When i try to compile with IMAP, it just thrown an error and say
error: utf8_mime2text() has old signature, but U8T_CANONICAL is present. This should not happen.
Check config.log for additional information.
I am trying to use imap-2007f from source. I did make on imap-2007f before compiling PHP and imap
relays on /usr/local/imap-2007f
I also tried imap-2007e.
And yes, libc-client and libc-client-devel is installed by RPM. But the version is 2007e. As i said
both 2007e and 2007f gives the same exact error.
Here is the config.log -> http://www.mediafire.com/?1qpg27j7xd19l6o
I built PHP many times with the exact this configure parameters before. All of them on CentOS 5.8. I
am getting this error on 6.3. Weird. Same parameters with centos 5.8 did the job.
Most weird thing is; If i only use --with-imap (without path) it gives me the same error.
Test script:
---------------
'./configure' '--build=x86_64-redhat-linux-gnu'
'--host=x86_64-redhat-linux-gnu' '--target=x86_64-redhat-linux-gnu'
'--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr'
'--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc'
'--datadir=/usr/share' '--includedir=/usr/include'
'--libdir=/usr/lib64' '--libexecdir=/usr/libexec'
'--localstatedir=/var' '--sharedstatedir=/usr/com'
'--mandir=/usr/share/man' '--infodir=/usr/share/info'
'--cache-file=../config.cache' '--with-libdir=lib64'
'--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d'
'--disable-debug' '--with-pic' '--disable-rpath'
'--without-pear' '--with-bz2' '--with-exec-dir=/usr/bin'
'--with-freetype-dir=/usr' '--with-png-dir=/usr' '--with-xpm-dir=/usr'
'--enable-gd-native-ttf' '--with-t1lib=/usr' '--without-gdbm'
'--with-gettext' '--with-gmp' '--with-iconv'
'--with-jpeg-dir=/usr' '--with-openssl' '--with-pcre-regex'
'--with-zlib' '--with-layout=GNU' '--enable-exif'
'--enable-ftp' '--enable-sockets' '--with-kerberos'
'--enable-ucd-snmp-hack' '--enable-shmop' '--enable-calendar'
'--with-libxml-dir=/usr' '--enable-libxml' '--with-xmlrpc'
'--enable-xml' '--with-system-tzdata' '--with-mhash'
'--with-mysql' '--with-gd' '--enable-dom' '--disable-dba'
'--without-unixODBC--disable-xmlreader' '--disable-xmlwriter'
'--without-sqlite' '--with-sqlite3' '--enable-phar'
'--enable-fileinfo' '--enable-json' '--without-pspell'
'--disable-wddx' '--disable-posix' '--disable-sysvmsg'
'--disable-sysvshm' '--disable-sysvsem' '--enable-pdo'
'--enable-mbstring' '--enable-fastcgi' '--with-mcrypt'
'--enable-fpm' '--with-mysqli=mysqlnd' '--with-pdo-mysql=mysqlnd'
'--enable-pcntl' '--with-imap=../imap-2007f' '--with-imap-ssl'
'--with-pgsql=/usr/pgsql-9.2' '--with-pdo-pgsql=/usr/pgsql-9.2'
'--with-curl=../curl-7.26.0'
Expected result:
----------------
PHP compiles as it did before on CentOS 5.8.
Actual result:
--------------
checking if your cpp allows macro usage in include lines... yes
checking for IMAP support... yes
checking for IMAP Kerberos support... yes
checking for IMAP SSL support... yes
checking for utf8_mime2text signature... (cached) old
checking for U8T_DECOMPOSE...
configure: error: utf8_mime2text() has old signature, but U8T_CANONICAL is present. This should not
happen. Check config.log for additional information.
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=62771&edit=1