Bug #62880 [Opn]: Problems building a shared mysqlnd extension
Edit report at https://bugs.php.net/bug.php?id=62880&edit=1
ID: 62880
Updated by: nikic@php.net
Reported by: lester at lsces dot co dot uk
Summary: Problems building a shared mysqlnd extension
Status: Open
Type: Bug
Package: MySQLi related
Operating System: Linux
PHP Version: 5.4.6
Block user comment: N
Private report: N
New Comment:
The error suggests that you are trying to build mysqlnd without zts and try to load it in a php
build with zts. Try adding --enable-maintainer-zts to your ./configure line.
Previous Comments:
------------------------------------------------------------------------
[2012-08-21 16:44:25] lester at lsces dot co dot uk
Description:
------------
This may be by design, but it is also being claimed that it does in fact work, so the main object of
this bug report is to get a documented confirmation of the situation.
Fixed bug http://bugs.php.net/55609 (mysqlnd cannot be built
shared). (Johannes) identifies the problem as having been fixed, but Rasmus claims that it is not
intended that mysqlnd should be built stand alone?
In any case when building as an apache2 module, a shared module is created, but will not load with
apache.
Test script:
---------------
./configure --with-apxs2=/opt/apache2/bin/apxs --prefix=/opt/php5
--with-config-file-path=/opt/apache2/conf --with-config-file-scan-dir=/opt/apache2/conf/php5.d
--enable-mysqlnd=shared --with-mysqli=shared
I'm sure that should be a "--with-mysqli=mysqlnd,shared" but that stops building of
./configure with a "can't find mysql" (Bug 50393)
Expected result:
----------------
mysqlnd.so and mysqli.so in the modules directory., which can be moved into the running PHP
installation.
Actual result:
--------------
When loading mysqlnd.so via apache, it fails with an PHP Warning: PHP Startup: Invalid library
(maybe not a PHP library) 'mysqlnd.so' in Unknown on line 0 on the latest build, but
I've also had
"Unable to load dynamic library '/opt/php5/ext/mysqlnd.so' -
/opt/php5/ext/mysqlnd.so: undefined symbol: executor_globals in Unknown on line 0" So I am
going to recheck everything on the next machine that needs updating
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=62880&edit=1
Thread (4 messages)