#18986 [NEW]: Unable to bind to server

From: Date: Tue, 20 Aug 2002 13:59:30 +0000
Subject: #18986 [NEW]: Unable to bind to server
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-17302@lists.php.net to get a copy of this message
From: luoy@muohio.edu Operating system: solaris 6 PHP version: 4.2.2 PHP Bug Type: LDAP related Bug description: Unable to bind to server compiling and installation was successful. But a single running of LDAP code failed. configure options: ./configure --without-mysql --with-oci8 --with-apxs=/usr/local/apache/bin/apxs --with-ldap=/usr/local --enable-xslt --with-xslt-sablot=/usr/local --with-iconv --with-ssl=/usr/local/ssl --enable-libgcc LDAP query test Connecting ...connect result is Resource id #1 Binding ... Warning: LDAP: Unable to bind to server: Can't contact LDAP server in /home/luoy/public_html/ldap.php on line 12 Bind result is ... From LDAP server side, we did not see bind request ( Ususally we can if we use some native tools like ldapseach) library dependence [luoy@admsol03:/home/luoy/src/php-4.1.2]$ldd /usr/local/apache/libexec/libphp4.so libdl.so.1 => /usr/lib/libdl.so.1 libpam.so.1 => /usr/dt/lib/libpam.so.1 libsablot.so.0 => /usr/local/lib/libsablot.so.0 libexpat.so.0 => /usr/local/lib/libexpat.so.0 libsched.so.1 => /usr/lib/libsched.so.1 libsocket.so.1 => /usr/lib/libsocket.so.1 libnsl.so.1 => /usr/lib/libnsl.so.1 libldap.so.2 => /usr/local/lib/libldap.so.2 liblber.so.2 => /usr/local/lib/liblber.so.2 libresolv.so.2 => /usr/lib/libresolv.so.2 libm.so.1 => /usr/lib/libm.so.1 libclntsh.so.8.0 => /opt/oracle/product/817/lib/libclntsh.so.8.0 libc.so.1 => /usr/lib/libc.so.1 libmp.so.2 => /usr/lib/libmp.so.2 libwtc8.so => /opt/oracle/product/817/lib/libwtc8.so libaio.so.1 => /usr/lib/libaio.so.1 /usr/platform/SUNW,Ultra-5_10/lib/libc_psr.so.1 -- Edit bug report at http://bugs.php.net/?id=18986&edit=1 -- Try a CVS snapshot: http://bugs.php.net/fix.php?id=18986&r=trysnapshot Fixed in CVS: http://bugs.php.net/fix.php?id=18986&r=fixedcvs Fixed in release: http://bugs.php.net/fix.php?id=18986&r=alreadyfixed Need backtrace: http://bugs.php.net/fix.php?id=18986&r=needtrace Try newer version: http://bugs.php.net/fix.php?id=18986&r=oldversion Not developer issue: http://bugs.php.net/fix.php?id=18986&r=support Expected behavior: http://bugs.php.net/fix.php?id=18986&r=notwrong Not enough info: http://bugs.php.net/fix.php?id=18986&r=notenoughinfo Submitted twice: http://bugs.php.net/fix.php?id=18986&r=submittedtwice register_globals: http://bugs.php.net/fix.php?id=18986&r=globals

« previous php.bugs (#17302) next »