Bug #62886 [Asn->Fbk]: PHP-FPM may segfault/hang on startup
| From: | fat@php.net | Date: | Wed, 26 Sep 2012 19:31:50 +0000 |
| Subject: | Bug #62886 [Asn->Fbk]: PHP-FPM may segfault/hang on startup | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-173723@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=62886&edit=1
ID: 62886
Updated by: fat@php.net
Reported by: pierre at archlinux dot de
Summary: PHP-FPM may segfault/hang on startup
-Status: Assigned
+Status: Feedback
Type: Bug
Package: FPM related
Operating System: Arch Linux
PHP Version: 5.4.6
Assigned To: fat
Block user comment: N
Private report: N
New Comment:
Can you please test the following path ?
The commit you mentioned to be faulty in fact did the following things:
when daemonize, the calling process waited 10s for the master process (which
have been forked just before) to send USR1 if OK or USR2 otherwise.
There must be a problem with some external libraries using USR1 and USR2.
I've removed the signal stuff and have it replaced by a pipe(2).
Can you please test and tell me if it fix your problem (which I never been able
to reproduce on my side).
thx
++ fat
Previous Comments:
------------------------------------------------------------------------
[2012-09-26 19:28:24] fat@php.net
The following patch has been added/updated:
Patch Name: bug62886.patch.txt
Revision: 1348687704
URL: https://bugs.php.net/patch-display.php?bug=62886&patch=bug62886.patch.txt&revision=1348687704
------------------------------------------------------------------------
[2012-09-20 10:40:48] hsatac at golang dot tw
Having the same issue.
Archlinux + PHP 5.4.7
------------------------------------------------------------------------
[2012-09-17 09:59:00] pierre at archlinux dot de
It also crashes with the imap extension disabled. But it seems the number of enabled extensions
might matter.
Anyway, we have a backtrace and the commit that introduced this issue.
------------------------------------------------------------------------
[2012-09-17 09:55:04] daniel at bashgeek dot net
Have the same problem on my end with a couple of servers. For me the problem is solved as soon as I
disable the IMAP extension of PHP. Maybe it has something todo with this extension?
------------------------------------------------------------------------
[2012-09-12 16:32:02] jeffrey dot ness at rackspace dot com
I am also noticing this issue with our 5.3.16 packages:
# php-fpm -v
PHP 5.3.16 (fpm-fcgi) (built: Aug 20 2012 10:39:20)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies
# for i in {1..100}; do php-fpm ; killall php-fpm; done
Segmentation fault
Segmentation fault
Segmentation fault
# dmesg | grep php-fpm
php-fpm[30800]: segfault at 7f7d199f4cd0 ip 00007f7d24a43b83 sp 00007fffdd48fb20 error 4 in ld-
2.12.so[7f7d24a35000+20000]
php-fpm[31599]: segfault at 7f50f17c3cd0 ip 00007f50fc812b83 sp 00007fff09f13120 error 4 in ld-
2.12.so[7f50fc804000+20000]
php-fpm[32009]: segfault at 7f3005f59cc0 ip 00007f3010938b83 sp 00007fffb291c3a0 error 4 in ld-
2.12.so[7f301092a000+20000]
php-fpm[32313]: segfault at 7f17094a4cc0 ip 00007f1713e83b83 sp 00007fffaab94e20 error 4 in ld-
2.12.so[7f1713e75000+20000]
php-fpm[32585]: segfault at 7f60ad427cc0 ip 00007f60b7e06b83 sp 00007ffff44e06a0 error 4 in ld-
2.12.so[7f60b7df8000+20000]
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=62886
--
Edit this bug report at https://bugs.php.net/bug.php?id=62886&edit=1