Bug #48451 [NoF->Wfx]: Compile fails "configure: error: Please reinstall the iconv library"
| From: | rasmus@php.net | Date: | Tue, 02 Oct 2012 00:37:28 +0000 |
| Subject: | Bug #48451 [NoF->Wfx]: Compile fails "configure: error: Please reinstall the iconv library" | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-173852@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=48451&edit=1
ID: 48451
Updated by: rasmus@php.net
Reported by: jordon at envygeeks dot com
Summary: Compile fails "configure: error: Please reinstall
the iconv library"
-Status: No Feedback
+Status: Wont fix
Type: Bug
Package: Compile Failure
Operating System: Ubuntu Intrepid
PHP Version: 6CVS-2009-06-02 (snap)
Block user comment: N
Private report: N
New Comment:
Sorry, we don't support 5.2.x anymore. Re-open if you can reproduce in 5.3.x or
5.4.x.
Previous Comments:
------------------------------------------------------------------------
[2012-10-02 00:16:23] dscotese at litmocracy dot com
This is happening to me with PHP Version 5.2.17. Here is what my configure had:
'./configure' \
'--prefix=/usr/src/php-5.2.17' \
'--datadir=/usr/share/php5' \
'--mandir=/usr/share/man' \
'--bindir=/usr/bin' \
'--with-libdir=lib64' \
'--includedir=/usr/include' \
'--sysconfdir=/etc/php5/apache2' \
'--with-config-file-path=/etc/php5/apache2' \
'--with-config-file-scan-dir=/etc/php5/conf.d' \
'--with-exec-dir=/usr/lib64/php5/bin' \
'--enable-magic-quotes' \
'--enable-libxml' \
'--enable-session' \
'--with-mm' \
'--with-pcre-regex' \
'--enable-xml' \
'--enable-simplexml' \
'--enable-spl' \
'--enable-safe-mode' \
'--enable-sigchild' \
'--disable-debug' \
'--enable-inline-optimization' \
'--enable-zend-multibyte' \
'--with-mysql=/usr' \
'--with-mssql=/usr/src/freetds-0.82' \
'--with-gd=shared' \
'--with-apxs2=/usr/sbin/apxs2' \
'--disable-all' \
'--disable-cli' \
'--with-pear=/usr/share/php5/PEAR' \
'--enable-bcmath=shared' \
'--enable-calendar=shared' \
'--enable-ctype=shared' \
'--enable-dbase=shared' \
'--enable-dom=shared' \
'--enable-exif=shared' \
'--enable-filepro=shared' \
'--enable-ftp=shared' \
'--enable-mbstring=shared' \
'--enable-mbregex' \
'--enable-pcntl=shared' \
'--enable-posix=shared' \
'--enable-shmop=shared' \
'--enable-ucd-snmp-hack' \
'--enable-soap=shared' \
'--enable-sockets=shared' \
'--enable-sysvmsg=shared' \
'--enable-sysvsem=shared' \
'--enable-sysvshm=shared' \
'--enable-tokenizer=shared' \
'--enable-wddx=shared' \
'--with-zlib=shared' \
'--with-bz2=shared' \
'--with-curl=shared' \
'--with-gd=shared' \
'--enable-gd-jis-conv' \
'--enable-gd-native-ttf' \
'--with-xpm-dir=/usr/X11' \
'--with-zlib-dir=/usr' \
'--with-gettext=shared' \
'--with-gmp=shared' \
'--with-iconv=shared,/usr/local' \
'--with-kerberos' \
'--with-config-file-scan-dir=/etc/php5/conf.d'
And /usr/local/bin contains:
MYSERVER:/usr/local/bin # ls
bsqldb freebcp neon-config svnlook wrjpgcom
cjpeg iconv osql svnserve xml2-config
...
I tried with the extra line:
LDFLAGS="-L/usr/local/lib/ -liconv" ./configure ...
But I still couldn't get configure to complete without "Please reinstall the iconv
library." I finally gave up and replaced the function that used iconv to simply return the
input string instead of converting it. I suppose that can lead to other problems, so I'll look
back here for guidance.
------------------------------------------------------------------------
[2009-07-20 15:05:56] ville dot solarius at gmail dot com
I was able to compile this with the configure line:
LDFLAGS="-L/usr/local/lib/ -liconv" ./configure
Yeah, I know, it is a little bit ugly way to round it, but hey, it works :)
Because the problem seems to be, that in certain conditions (sorry, I don't know what those
are, but I am having that ;)) it seems that "configure" is not putting "-liconv"
to the test compilation line. Hence, it was possible to override with line we can see above.
But well, my system is 64bit (amd), OpenBSD 4.5 with GNU iconv 1.13.1 and php 5.3.0.
It is compiling now, but not finished yet, so I can't really be sure is that working. But the
configure is now running fine.
------------------------------------------------------------------------
[2009-07-06 01:00:00] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
------------------------------------------------------------------------
[2009-06-28 18:08:07] kalle@php.net
Does this happen with any of the 5.x branches? 5.2.10 or 5.3.0RCX?
------------------------------------------------------------------------
[2009-06-02 13:44:30] jordon at envygeeks dot com
Description:
------------
Compile fails with:
checking for iconv support... yes
configure: error: Please reinstall the iconv library.
Cat of the last few lines of Config.log:
configure: In function 'main':
configure:40147: warning: incompatible implicit declaration of built-in function 'exit'
configure:40173: checking size of int
configure:40213: checking size of long
configure:40253: checking size of long long
configure:40622: checking for iconv support
Reproduce code:
---------------
Configuration line:
./configure --mandir=/usr/share/man --prefix=/usr \
--sbindir=/usr/sbin/ --bindir=/usr/bin/ \
--enable-calendar --enable-ctype --enable-bcmath \
--enable-exif --enable-ftp --enable-mbstring \
--enable-sockets --enable-wddx --enable-soap --enable-zip
--enable-cgi --enable-cli --enable-gd-native-ttf --enable-libxml \
--disable-gcov --disable-debug --disable-rpath \
--disable-static --disable-shmop --disable-sysvsem --disable-sysvshm
--disable-sysvmsg --with-regex=php --with-pic=/usr \
--with-layout=GNU --with-bz2=/usr --with-iconv=/usr \
--with-gettext=/usr --with-pcre-regex=/usr --with-libxml-dir=/usr \
--with-zlib=/usr --with-openssl=/usr --with-curl=/usr --with-mysql \
--with-mcrypt --with-gd=shared --with-mhash \
--without-gdbm --without-db1 --withou-db2 --without-db3 --without-db4
Expected result:
----------------
Success!
Actual result:
--------------
Fail.
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=48451&edit=1