Bug #52034 [Fbk->NoF]: PHP programmer

From: Date: Mon, 18 Feb 2013 00:34:19 +0000
Subject: Bug #52034 [Fbk->NoF]: PHP programmer
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-176864@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=52034&edit=1 ID: 52034 Updated by: php-bugs@lists.php.net Reported by: hettbox at gmail dot com Summary: PHP programmer -Status: Feedback +Status: No Feedback Type: Bug Package: Unknown/Other Function Operating System: Windows 2008 x86 PHP Version: 5.3.2 New Comment: No feedback was provided. The bug is being suspended because we assume that you are no longer experiencing the problem. If this is not the case and you are able to provide the information that was requested earlier, please do so and change the status of the bug back to "Open". Thank you. Previous Comments: ------------------------------------------------------------------------ [2010-06-10 14:34:30] hettbox at gmail dot com This problem detected on WINDOWS only. ------------------------------------------------------------------------ [2010-06-10 12:19:37] hettbox at gmail dot com <?php ini_set('max_execution_time', 5); sleep(6); echo 'is ok!'; ?> ------------------------------------------------------------------------ [2010-06-10 12:14:42] hettbox at gmail dot com Try! <?php sleep(31); echo 'is ok!'; ?> Result: Fatal error: Maximum execution time of 30 seconds exceeded in D:\wwwroot\host\tmp\check.php on line 4 ------------------------------------------------------------------------ [2010-06-10 11:41:46] hettbox at gmail dot com If configure server on max_execution_time more 30 seconds (for example 3600), then !!!after 30 secons!!! server generated error "Fatal error: Maximum execution time of !!!3600 seconds!!! exceeded" Server generating error on max_execution_time! Плохо с английским. Попробую по русски. Во время выполнения скрипта не должно входить время на загрузку файла, на сколько мне известно. В предыдущих версиях PHP так и было, но в версии PHP 5.3.2 по каким-то непонятным причинам это стало учитываться. ------------------------------------------------------------------------ [2010-06-10 11:41:36] hettbox at gmail dot com If configure server on max_execution_time more 30 seconds (for example 3600), then !!!after 30 secons!!! server generated error "Fatal error: Maximum execution time of !!!3600 seconds!!! exceeded" Server generating error on max_execution_time! Плохо с английским. Попробую по русски. Во время выполнения скрипта не должно входить время на загрузку файла, на сколько мне известно. В предыдущих версиях PHP так и было, но в версии PHP 5.3.2 по каким-то непонятным причинам это стало учитываться. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at https://bugs.php.net/bug.php?id=52034 -- Edit this bug report at https://bugs.php.net/bug.php?id=52034&edit=1

« previous php.bugs (#176864) next »