Req #54593 [Fbk->NoF]: No 441 (request URI too long) issued.

From: Date: Mon, 18 Feb 2013 00:34:49 +0000
Subject: Req #54593 [Fbk->NoF]: No 441 (request URI too long) issued.
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-176990@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=54593&edit=1

 ID:               54593
 Updated by:       php-bugs@lists.php.net
 Reported by:      sven at democopei dot de
 Summary:          No 441 (request URI too long) issued.
-Status:           Feedback
+Status:           No Feedback
 Type:             Feature/Change Request
 Package:          HTTP related
 Operating System: Linux
 PHP Version:      5.3.6

 New Comment:

No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


Previous Comments:
------------------------------------------------------------------------
[2011-04-23 18:14:31] johannes@php.net

Please try using this snapshot:

  http://snaps.php.net/php5.3-latest.tar.gz
 
For Windows:

  http://windows.php.net/snapshots/

You are using a patched version of PHP (dotdeb + suhoshin patch) We have no control over the things
in there. Please try with vanilla PHP. I also suspect this might be caused by the web server rather
than PHP.

------------------------------------------------------------------------
[2011-04-23 15:53:59] sven at democopei dot de

If forgot to tell that the problem occurred after an update. php -v says:

PHP 5.3.6-6~dotdeb.0 with Suhosin-Patch (cli) (built: Apr 17 2011 12:27:20) 
Copyright (c) 1997-2011 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2011 Zend Technologies
    with Suhosin v0.9.32.1, Copyright (c) 2007-2010, by SektionEins GmbH

------------------------------------------------------------------------
[2011-04-22 20:33:58] dtajchreber@php.net

Things don't just randomly change. Did you upgrade PHP? Did you upgrade your 
httpd? Did you change something? Need more information...

------------------------------------------------------------------------
[2011-04-22 17:26:47] sven at democopei dot de

Description:
------------
Since yesterday PHP just throws large GET data away instead of issuing the error.

Test script:
---------------
<? echo $_GET['some_too_long_request'] ?>

Expected result:
----------------
Error 441: Request URI too long.

Actual result:
--------------
An empty document. No error log.


------------------------------------------------------------------------



-- 
Edit this bug report at https://bugs.php.net/bug.php?id=54593&edit=1


Thread (5 messages)

« previous php.bugs (#176990) next »