Bug #62726 [Fbk->NoF]: FPM fails to spawn when max_children is set to a high number
| From: | php-bugs at lists dot php dot net | Date: | Mon, 18 Feb 2013 00:35:57 +0000 |
| Subject: | Bug #62726 [Fbk->NoF]: FPM fails to spawn when max_children is set to a high number | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-177119@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=62726&edit=1
ID: 62726
Updated by: php-bugs@lists.php.net
Reported by: olemarkus@php.net
Summary: FPM fails to spawn when max_children is set to a high
number
-Status: Feedback
+Status: No Feedback
Type: Bug
Package: FPM related
Operating System: Gentoo Linux
PHP Version: 5.4.5
New Comment:
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
Previous Comments:
------------------------------------------------------------------------
[2012-09-27 23:29:54] fat@php.net
Please try using this snapshot:
http://snaps.php.net/php5.4-latest.tar.gz
For Windows:
http://windows.php.net/snapshots/
------------------------------------------------------------------------
[2012-08-05 12:16:54] wer at wereveal dot com
Discovered that I am experiencing the same problem with PHP 5.3.15 on Gentoo. php-
fpm refuses to start correctly. It hangs although the child processes are started
and continue to work even after kill -9 on the main command
/usr/lib/php5.3/bin/php-fpm -y /etc/php/fpm-php5.3/php-fpm.conf -g /var/run/php-
fpm-php5.3.pid
Changing the pm.max_children did not seem to fix this for me and I am using pm =
dynamic.
Works fine with PHP 5.3.14
------------------------------------------------------------------------
[2012-08-02 12:07:43] olemarkus@php.net
Description:
------------
With the following parameters set in php-fpm.conf, FPM refuse to start properly.
The worker threads are spawned, but hangs and only a kill -9 will stop them.
Setting pm.max_children to a lower number works.
The exact config works with PHP 5.4.4.
pm = static
pm.max_children = 500
Some additional information can be found in downstream bug
https://bugs.gentoo.org/show_bug.cgi?id=428194
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=62726&edit=1