#12061 [Com]: CGI Error
| From: | poser187 at hotmail dot com | Date: | Sat, 24 Aug 2002 16:08:30 +0000 |
| Subject: | #12061 [Com]: CGI Error | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-17763@lists.php.net to get a copy of this message | ||
ID: 12061
Comment by: poser187@hotmail.com
Reported By: peters@connection.ca
Status: Bogus
Bug Type: IIS related
Operating System: Win 2K
PHP Version: 4.0.6
New Comment:
For those of you getting a CGI ERROR when trying to run PHPmyAdmin from
IIS (e.g. http://localhost/path_to_your_phpmyadmin_install/
..
Look at your config.inc file under "$cfg['PmaAbsoluteUri'] = " and make
sure that you have not included and extra space between the ending /
and the closing quotation mark.
Do this: ... ='http://localhost/phpmyadmin/'
Not This: ... ='http://localhost/phpmyadmin/ '
If this is the cause of your problem you will see a /%20%/ between
localhost and /phpmyadmin. All that is happening is an extra space is
being input into your html. Simple fix. Hope this helps some of you.
Previous Comments:
------------------------------------------------------------------------
[2002-06-18 17:42:34] author@theholmesplace.com
Regarding the CGI Header problem, I ran into the same thing, but had to
perform a different solution (due to a stupid thing on my part).
Anyways, I have Windows 2000 running IIS 5.0 latest of everything -
meaning SP2 for W2K and PHP 4.2.1 and MySQL 4.0 and phpMyAdmin like
2.2.6 and when I installed the phpMyAdmin I changed the index.php file
to default.php cause that's what I need for IIS to pick it up, I don't
have it set up to see index.php.
Yeah so, I know I'm stupid, but that was the problem (simple).
Solution: I made a copy of the file and renamed it to index.php
Result: The directory I had had the two files, index.php and
default.php. Everything worked!
FYI
------------------------------------------------------------------------
[2002-06-05 18:33:50] ae3k@msn.com
When I try to go to install.php I get a bunch of errors:
Parse error: parse error, unexpected T_STRING in
C:\Inetpub\mohaapms\phpmyadmin\config.inc.php on line 36
Notice: Undefined variable: cfgOBGzip in
C:\Inetpub\mohaapms\phpmyadmin\header.inc.php on line 10
Warning: Cannot add header information - headers already sent by
(output started at C:\Inetpub\mohaapms\phpmyadmin\config.inc.php:36) in
C:\Inetpub\mohaapms\phpmyadmin\header.inc.php on line 23
Warning: Cannot add header information - headers already sent by
(output started at C:\Inetpub\mohaapms\phpmyadmin\config.inc.php:36) in
C:\Inetpub\mohaapms\phpmyadmin\header.inc.php on line 24
Warning: Cannot add header information - headers already sent by
(output started at C:\Inetpub\mohaapms\phpmyadmin\config.inc.php:36) in
C:\Inetpub\mohaapms\phpmyadmin\header.inc.php on line 25
Warning: Cannot add header information - headers already sent by
(output started at C:\Inetpub\mohaapms\phpmyadmin\config.inc.php:36) in
C:\Inetpub\mohaapms\phpmyadmin\header.inc.php on line 26
Warning: Cannot add header information - headers already sent by
(output started at C:\Inetpub\mohaapms\phpmyadmin\config.inc.php:36) in
C:\Inetpub\mohaapms\phpmyadmin\header.inc.php on line 27
Notice: Undefined variable: charset in
C:\Inetpub\mohaapms\phpmyadmin\header.inc.php on line 29
Warning: Cannot add header information - headers already sent by
(output started at C:\Inetpub\mohaapms\phpmyadmin\config.inc.php:36) in
C:\Inetpub\mohaapms\phpmyadmin\header.inc.php on line 29
Notice: Undefined variable: text_dir in
C:\Inetpub\mohaapms\phpmyadmin\header.inc.php on line 38
Notice: Undefined variable: strPmaUriError in
C:\Inetpub\mohaapms\phpmyadmin\libraries\common.lib.php on line 384
I'm running win2k adv. server.
Any help would be great, thanks.
------------------------------------------------------------------------
[2002-05-07 14:14:13] jweldin@unypunk.com
on win2k with iis5 i had the same "frame with two cgi errors" issue,
adding the iusr_mybox (anonymous inet user) to the security settings
and giving him read/write/exec worked for me.
(for noobs: browse to phpMyAdmin folder in explorer, right click choose
properties, choose security tab, add the iusr_yourboxnamehere
account... then select that account and give more permissions..
basically he needs to be able to execute and read... if that doesn't
work.. give it full and take away until it doesn't work, then you will
know what you need to give that user.)
------------------------------------------------------------------------
[2002-04-24 10:37:08] afirato@hotmail.com
If i open "http://localhost\phpmyadmin"
(APACHE) i become 2 Errors.
The prodecure entry point zend_list_find couldnt be located in the
dynamic link library php4ts.dll and Unable to Load dynamic library
'c:\apache\php4\extensions\php_gd.dll' - The specified procedure
couldnt be found.
What can i do??????
Pls i need help i am a noob :-(
------------------------------------------------------------------------
[2002-04-23 17:19:45] roberto@studenten.net
I have the following error:
Undefined variable $strFlushTable at 1264 from a file!
How can I solve this problem.
I am a newbie in PHP!
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/12061
--
Edit this bug report at http://bugs.php.net/?id=12061&edit=1