Bug #64627 [Opn->Fbk]: Unable to load dynamic library 'C:\Program Files (x86)\PHP\5.4.13\ext\php_ldap.
Edit report at https://bugs.php.net/bug.php?id=64627&edit=1
ID: 64627
Updated by: ab@php.net
Reported by: jonathan at snetram dot nl
Summary: Unable to load dynamic library 'C:\Program Files
(x86)\PHP\5.4.13\ext\php_ldap.
-Status: Open
+Status: Feedback
Type: Bug
Package: LDAP related
Operating System: Windows 7 64 bit
PHP Version: 5.4.13
Block user comment: N
Private report: N
New Comment:
php_ldap.dll depends on a number of libs like openssl or sasl, please make sure those libs are on
the path when starting webserver. Do you run phpinfo() in cli or webserver? If -m works, phpinfo (or
just -i) should also work in console. Please check that.
Previous Comments:
------------------------------------------------------------------------
[2013-04-10 20:19:36] jonathan at snetram dot nl
Description:
------------
When loading php_ldap as an extension in PHP 5.4.13 on Windows 7 64bit I seem to not be able to work
with LDAP and found the following error in the eventvwr after loading my webserver:
Unable to load dynamic library 'C:\Program Files (x86)\PHP\5.4.13\ext\php_ldap.dll' - %1
is not a valid Win32 application.
It seems there is a compatability issue with this DLL.
Expected result:
----------------
No error when loading php_ldap.dll and LDAP functionality working
Actual result:
--------------
I checked php -m and it lists the ldap module being loaded, however phpinfo() doesn't seem to
think so.
Other libraries like php_bz2.dll are loaded without problems, they show up in the output of both php
-m and phpinfo();
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=64627&edit=1
Thread (3 messages)