Req #64727 [Opn->Sus]: PHP does not abide by RFC6628 when ending headers
| From: | rasmus@php.net | Date: | Sat, 27 Apr 2013 06:24:57 +0000 |
| Subject: | Req #64727 [Opn->Sus]: PHP does not abide by RFC6628 when ending headers | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-178669@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=64727&edit=1
ID: 64727
Updated by: rasmus@php.net
Reported by: andrew dot heebner at gmail dot com
Summary: PHP does not abide by RFC6628 when ending headers
-Status: Open
+Status: Suspended
Type: Feature/Change Request
Package: HTTP related
Operating System: All
PHP Version: 5.5.0beta4
Block user comment: N
Private report: N
New Comment:
I assume you mean RFC6648. 6288 has nothing to do with this. And technically
RFC6648 does not take a stance on what to do with existing X- headers:
4. Makes no recommendation as to whether existing "X-" parameters
ought to remain in use or be migrated to a format without the
"X-"; this is a matter for the creators or maintainers of those
parameters.
Until there is a new convention for this, we are not going to change it as it
would break all the clients out there that rely on it.
Previous Comments:
------------------------------------------------------------------------
[2013-04-27 01:12:35] andrew dot heebner at gmail dot com
Description:
------------
As per RFC6288, X-* header values are deprecated. PHP stills sets the X-Powered-
By header, which is obviously outdated as per the RFC.
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=64727&edit=1