Bug #64924 [Nab]: 500 internal server error caused by PHP but nothing logged in error log
| From: | rasmus@php.net | Date: | Mon, 27 May 2013 14:44:43 +0000 |
| Subject: | Bug #64924 [Nab]: 500 internal server error caused by PHP but nothing logged in error log | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-179162@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=64924&edit=1
ID: 64924
Updated by: rasmus@php.net
Reported by: matteosistisette at gmail dot com
Summary: 500 internal server error caused by PHP but nothing
logged in error log
Status: Not a bug
Type: Bug
Package: *Web Server problem
Operating System: ubuntu 12.10
PHP Version: 5.4.15
Block user comment: N
Private report: N
New Comment:
There is no bug. Your custom error handler is explicitly sending a 500. We do not
need to see it.
Previous Comments:
------------------------------------------------------------------------
[2013-05-27 14:33:28] matteosistisette at gmail dot com
spam spam spam spam spam spam spam spam spam spam spam
Now my next comment will be the code, which is valuable information to fix the
bug, but it won't let me post it
------------------------------------------------------------------------
[2013-05-27 14:32:29] rasmus@php.net
.
------------------------------------------------------------------------
[2013-05-27 14:32:15] matteosistisette at gmail dot com
It's unbelievable. I can post any sort of stupid blah bla blah, but if I try to
paste a snippet of code it rejects it at spam.
------------------------------------------------------------------------
[2013-05-27 14:31:30] matteosistisette at gmail dot com
Good catch.
It's almost certainly the error handler.
However, while I try to paste the code here, this broken bugtracker keeps
rejecting it as spam.
------------------------------------------------------------------------
[2013-05-27 14:01:11] rasmus@php.net
I really doubt this is crashing PHP. I would have a look at any custom error
handler you have in place and look at what it does with Illegal Offset warnings.
This is a new warning in PHP 5.4 which you get if you try to use a string as if
it was an associative array, since this is what you are doing in this case.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=64924
--
Edit this bug report at https://bugs.php.net/bug.php?id=64924&edit=1