#14424 [Com]: is_readable returns error if file does not exist.

From: Date: Tue, 27 Aug 2002 21:04:04 +0000
Subject: #14424 [Com]: is_readable returns error if file does not exist.
References: 1  Groups: php.bugs php.doc 
Request: Send a blank email to php-bugs+get-17966@lists.php.net to get a copy of this message
ID: 14424 Comment by: cvb@clausvb.de Reported By: jm@tv3ooo.nl Status: Closed Bug Type: Documentation problem Operating System: Suse linux 7.2 PHP Version: 4.1.0 New Comment: We encoutered this bug yesterday. Suse linux 8.0 is using PHP 4.1.0 and so this bug applies here I think. Since it was fixed in 4.1.2 (or 4.1.1) I think anyone who encounters this bug should upgrade. Best regards, ClausVB Previous Comments: ------------------------------------------------------------------------ [2001-12-12 15:21:16] goba@php.net This is what we call an accidental problem. Things like this can happen in such a big project as PHP. Goba ------------------------------------------------------------------------ [2001-12-12 11:37:37] sniper@php.net This is fixed in CVS long time ago. The change didn't make it to 4.1.0 though. --Jani ------------------------------------------------------------------------ [2001-12-12 10:17:27] jm@tv3ooo.nl So that is what you call downwards compatible? I build a site under 4.0.6, it works fine. There is an update to PHP, my sites break. ------------------------------------------------------------------------ [2001-12-12 06:40:15] sander@php.net So what's the problem? is_readable now returns an error, which is IMHO fine. The only problem is that it's not documented. Changing to docu prob. ------------------------------------------------------------------------ [2001-12-11 08:22:39] jm@tv3ooo.nl Code example: if (is_readable("foo")) { echo "file exists.<P>"; } else { echo "file does not exist.<P>"; } Error message: Warning: stat failed for foo (errno=2 - No such file or directory) in /home/xxx/public_html/is_readable.php on line 3 Configure options: ./configure --with-apache=/home/xxx/apache_1.3.22 --with-mysql=/usr/local --with-gd=/usr/local --with-zlib-dir=/usr/local --with-png-dir=/usr --with-jpeg-dir=/home/xxx/jpeg-6b --with-xpm-dir=/usr/X11R6 --with-ttf --with-curl Seems similar to is_file() bug. Problem does not occur on older versions (i.e. 4.0.6). ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=14424&edit=1

« previous php.bugs (#17966) next »