Bug #62317 [Opn->Wfx]: Session upload progress returns empty array if files larger than post_max_size
| From: | arpad@php.net | Date: | Thu, 27 Jun 2013 19:19:47 +0000 |
| Subject: | Bug #62317 [Opn->Wfx]: Session upload progress returns empty array if files larger than post_max_size | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-179900@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=62317&edit=1
ID: 62317
Updated by: arpad@php.net
Reported by: scott at phphq dot net
Summary: Session upload progress returns empty array if files
larger than post_max_size
-Status: Open
+Status: Wont fix
Type: Bug
Package: Session related
Operating System: Win Server 2003 x86 / IIS 6
PHP Version: 5.4.3
Block user comment: N
Private report: N
New Comment:
When files exceed upload_max_filesize, the progress data does return an error.
However when the content length of the request exceeds post_max_size, a warning is raised and all
upload processing is skipped.
In order to provide errors in the progress data in this case, we'd have to keep processing the
request just to find out if there's any files to report the errors on.
If you're regularly checking the progress data, it would make sense to consider the absence of
any progress data after a certain threshold, an error in itself.
Previous Comments:
------------------------------------------------------------------------
[2012-06-13 20:27:15] scott at phphq dot net
Description:
------------
I am submitting this as a bug because PHP will instantly return an empty $_SESSION
array if the file size sum of all uploaded files is larger than allowed by
post_max_size or upload_max_filesize even though the browser continues to upload.
I would expect that PHP would automatically cancel these uploads, or at least
return an error so I can use $_SESSION[key]['cancel_upload']; myself.
I'm on PHP 5.4.3, Win Server 2003 x86, IIS6 as fast_cgi.
session.upload_progress.cleanup is turned off so I could try and debug this. It's
not happening because of the cleanup process.
Test script:
---------------
Here is what you can use to duplicate the issue:
http://phphq.net/_upbug/
Expected result:
----------------
I would expect some sort of error.
Actual result:
--------------
Null responce
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=62317&edit=1