Req #43574 [Opn->Csd]: unclear error message on allow_url_fopen=0
Edit report at https://bugs.php.net/bug.php?id=43574&edit=1
ID: 43574
Updated by: yohgaki@php.net
Reported by: greg at chiaraquartet dot net
Summary: unclear error message on allow_url_fopen=0
-Status: Open
+Status: Closed
Type: Feature/Change Request
Package: Streams related
Operating System: n/a
PHP Version: 5.3CVS-2007-12-12 (CVS)
-Assigned To:
+Assigned To: yohgaki
Block user comment: N
Private report: N
New Comment:
Already fixed.
Previous Comments:
------------------------------------------------------------------------
[2007-12-12 03:35:31] greg at chiaraquartet dot net
Description:
------------
if one tries to use the data stream (or any url-based stream), the error message is:
%s:// wrapper is disabled in the server configuration
It would be more helpful if it said:
s:// wrapper is disabled in the server configuration by allow_url_fopen=0
Reproduce code:
---------------
Index: main/streams/streams.c
===================================================================
RCS file: /repository/php-src/main/streams/streams.c,v
retrieving revision 1.82.2.6.2.18.2.1
diff -u -r1.82.2.6.2.18.2.1 streams.c
--- main/streams/streams.c 6 Nov 2007 11:02:36 -0000 1.82.2.6.2.18.2.1
+++ main/streams/streams.c 12 Dec 2007 03:33:09 -0000
@@ -1621,7 +1621,7 @@
if (options & REPORT_ERRORS) {
/* protocol[n] probably isn't '\0' */
char *protocol_dup = estrndup(protocol, n);
- php_error_docref(NULL TSRMLS_CC, E_WARNING, "%s:// wrapper is disabled
in the server configuration", protocol_dup);
+ php_error_docref(NULL TSRMLS_CC, E_WARNING, "%s:// wrapper is disabled
in the server configuration by allow_url_fopen=0", protocol_dup);
efree(protocol_dup);
}
return NULL;
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=43574&edit=1
Thread (2 messages)