Bug #60749 [Com]: SNMP module should not strip non-standard SNMP port from hostname
| From: | hexetic at gmail dot com | Date: | Wed, 11 Sep 2013 17:32:08 +0000 |
| Subject: | Bug #60749 [Com]: SNMP module should not strip non-standard SNMP port from hostname | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-181525@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=60749&edit=1
ID: 60749
Comment by: hexetic at gmail dot com
Reported by: lytboris@php.net
Summary: SNMP module should not strip non-standard SNMP port
from hostname
Status: No Feedback
Type: Bug
Package: SNMP related
Operating System: *
PHP Version: 5.4.0RC5
Assigned To: lytboris
Block user comment: N
Private report: N
New Comment:
The fix checked-in seems to break passing-in "hostname:port" as $hostname to the snmp
functions, e.g.:
<?php
$host = "192.168.0.100:1616";
$rval = snmp2_get ($host, "whatever", "1.3.6.1.4.1.9.9.27");
print $host;
?>
After the call to snmp2_get, $host is "192.168.0.1001616" -- i.e., the colon has been
removed. As a result, calling snmp2_get or any of the other functional snmp parameters is likely to
fail after the first time.
We are experiencing this with the current version of PHP in Debian Squeeze, i.e.:
$ php --version
PHP 5.4.4-14+deb7u4 (cli) (built: Aug 23 2013 14:37:41)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies
The codebase for this version appears to have lytboris@php.net's patch.
Previous Comments:
------------------------------------------------------------------------
[2013-02-08 05:10:19] lytboris@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
------------------------------------------------------------------------
[2012-07-24 23:37:45] rasmus@php.net
Automatic comment on behalf of lytboris
Revision: http://git.php.net/?p=php-src.git;a=commit;h=583292ab221e98f1e9585412c515057626bccdd4
Log: Fixed bug #60585 (php build fails with USE flag snmp when IPv6 support is disabled) Fixed bug
#60749 (SNMP module should not strip non-standard SNMP port from hostname) Fixed ipv6 test skipto if
IPv6 support is disabled
------------------------------------------------------------------------
[2012-04-18 09:46:36] laruence@php.net
Automatic comment on behalf of lytboris
Revision: http://git.php.net/?p=php-src.git;a=commit;h=583292ab221e98f1e9585412c515057626bccdd4
Log: Fixed bug #60585 (php build fails with USE flag snmp when IPv6 support is disabled) Fixed bug
#60749 (SNMP module should not strip non-standard SNMP port from hostname) Fixed ipv6 test skipto if
IPv6 support is disabled
------------------------------------------------------------------------
[2012-01-13 18:48:17] lytboris@php.net
Please try using this snapshot:
http://snaps.php.net/php5.4-latest.tar.gz
For Windows:
http://windows.php.net/snapshots/
------------------------------------------------------------------------
[2012-01-13 18:46:27] lytboris@php.net
Automatic comment from SVN on behalf of lytboris
Revision: http://svn.php.net/viewvc/?view=revision&revision=322214
Log: merge from trunk:
Fixed bug #60585 (php build fails with USE flag snmp when IPv6 support is disabled
Fixed bug #60749 (SNMP module should not strip non-standard SNMP port from hostname
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=60749
--
Edit this bug report at https://bugs.php.net/bug.php?id=60749&edit=1