Bug #64445 [Fbk->NoF]: Cannot load php_soap.dll

From: Date: Tue, 15 Oct 2013 11:54:40 +0000
Subject: Bug #64445 [Fbk->NoF]: Cannot load php_soap.dll
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-182232@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=64445&edit=1

 ID:               64445
 Updated by:       php-bugs@lists.php.net
 Reported by:      blasterdrp at gmail dot com
 Summary:          Cannot load php_soap.dll
-Status:           Feedback
+Status:           No Feedback
 Type:             Bug
 Package:          Dynamic loading
 Operating System: Windows XP x86 SP3
 PHP Version:      5.4.13
 Private report:   N

 New Comment:

No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.


Previous Comments:
------------------------------------------------------------------------
[2013-03-21 10:21:29] ab@php.net

Just tried that with apache 2.4.4 and php 5.4.13 on win8. I could reproduce this only if I set a
relative path like extension_dir=ext, giving full path works. However that space in your path looks
suspicious to me, though it worked for me on win8 too. Could you please try to remove the space from
that path?

------------------------------------------------------------------------
[2013-03-19 13:12:49] blasterdrp at gmail dot com

PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\\Program
Files\\PHP\\5.4.13\\ext\\php_soap.dll' - The specified procedure could
not be found.\r\n in Unknown on line 0

------------------------------------------------------------------------
[2013-03-18 16:00:52] blasterdrp at gmail dot com

Description:
------------
Unzipped contents to a new PHP branch directory. Copied php.ini.development as 
php.ini then opened it side-by-side with previous php.ini (5.4.9) to ensure that 
the same settings had the same values to avoid hastily setting values for 
configurations I was not aware of.

I receive the following error message when starting my Apache server:

"PHP Startup: Unable to load dynamic library 'C:\Program 
Files\PHP\5.4.13\ext\php_soap.dll' - The specified procedure could not be 
found."

Navigating to that directory I can clearly see php_soap.dll. This is the only 
extension that will not load. I have also redownloaded PHP to ensure that this 
particular library was not corrupted.


php.ini:

extension_dir = "C:\Program Files\PHP\5.4.13\ext"

extension=php_soap.dll



------------------------------------------------------------------------



-- 
Edit this bug report at https://bugs.php.net/bug.php?id=64445&edit=1


Thread (4 messages)

« previous php.bugs (#182232) next »